Bug 234233 - xml-commons-apis is not compatible with the Sun JDK [NEEDINFO]
xml-commons-apis is not compatible with the Sun JDK
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xml-commons (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fernando Nasser
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-27 15:26 EDT by Matt Wringe
Modified: 2014-06-02 09:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:17:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (mwringe)


Attachments (Terms of Use)

  None (edit)
Description Matt Wringe 2007-03-27 15:26:11 EDT
Description of problem:
The upstream Sun JDK rpm has a virtual unversioned provides on xml-commons-apis.
We also have our own package called xml-commons-apis.
Due to certain rpm behaviors, these packages are incompatible.

When our xml-commons-apis package is updated, every other package that provides
xml-commons-apis will be removed (this includes the Sun JDK rpm). This means we
cannot have a package named xml-commons-apis. See
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=233713

The Sun JDK rpm also unversions its virtual provides of xml-commons-apis. This
means that no package can obsolete xml-commons-apis without removing the Sun
JDK. See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=229791

So we are stuck in a situation in which we need to rename the xml-commons-apis
package without obsoleting xml-commons-apis. But renaming a package requires
obsoleting the old naming to provide a smooth update path. 


Version-Release number of selected component (if applicable):
Any version of package xml-commons-apis

How reproducible:
Always

Steps to Reproduce:
1. Install the Sun JDK
2. Install the xml-commons-apis package
3. Update the xml-commons-apis package
  
Actual results:
The Sun JDK rpm is removed from the system

Expected results:
The xml-commons-apis package should not remove the JDK package

Additional info:
This will also affect any of the products using xml-commons-apis in RHEL4
Comment 1 RHEL Product and Program Management 2014-03-07 08:43:20 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:17:52 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.