Bug 23429 - gcc produces bad assembler code; assembler says "Error: immediate operand illegal with absolute jump"
gcc produces bad assembler code; assembler says "Error: immediate operand ill...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-05 12:59 EST by Jonathan Kamens
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-07 16:52:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed source file which compiles wrong with gcc 2.96 (106.60 KB, text/plain)
2001-01-05 12:59 EST, Jonathan Kamens
no flags Details
gcc 2.95 generated, OK assembler input (50.09 KB, text/plain)
2001-01-05 13:02 EST, Jonathan Kamens
no flags Details
gcc 2.96-generated, bad assembler input (48.59 KB, text/plain)
2001-01-05 13:02 EST, Jonathan Kamens
no flags Details

  None (edit)
Description Jonathan Kamens 2001-01-05 12:59:03 EST
I am currently using gcc-2.96-69 and binutils-2.10.1.0.2-1, but this
problem manifested itself with earlier versions of both packages, including
the versions shipped with stock RedHat 7.0.  I will attach a preprocessed
source file (Containers.i), the assembler file produced from this source by
gcc-2.96-69 (Containers-296.s), and the assembler file produced form this
source by gcc 2.95.2 (Containers-295.s).  The file Containers-296.s cannot
be assembled; attempts to do so yield many errors of the form shown in the
summary of this bug.  The file Containers-295.s *can* be assembled.  The
relevant difference between the two files appears to be lines of the form
"call dynamic_link_info_block+34010" in Containers-295.s vs. lines of the
form "call *$dynamic_link_info_block+34010" in Containers-296.s.

I am marking this bug "Red Hat Beta Program only" because the code in
Containers.i is part of a commercial product and I therefore do not want it
widely disseminated.  Since it is machine-generated, people are unlikely to
be able to do anything useful with it, but I would still like to limit its
distribution.
Comment 1 Jonathan Kamens 2001-01-05 12:59:53 EST
Created attachment 7106 [details]
preprocessed source file which compiles wrong with gcc 2.96
Comment 2 Jonathan Kamens 2001-01-05 13:02:19 EST
Created attachment 7107 [details]
gcc 2.95 generated, OK assembler input
Comment 3 Jonathan Kamens 2001-01-05 13:02:51 EST
Created attachment 7108 [details]
gcc 2.96-generated, bad assembler input
Comment 4 Jakub Jelinek 2001-01-07 16:52:00 EST
I've fixed this in http://gcc.gnu.org/ml/gcc-patches/2001-01/msg00509.html
and it will appear in the next gcc rpm (2.96-71).
Thanks.

Note You need to log in before you can comment on or make changes to this bug.