Bug 23434 - No netgroup support in nfs-utils-0.2.1-4
No netgroup support in nfs-utils-0.2.1-4
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: nfs-utils (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
David Lawrence
:
: 23849 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-05 13:43 EST by Jim Radford
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-12 13:09:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Radford 2001-01-05 13:43:33 EST
exportfs complains that netgroup support is not compiled in.
Comment 1 Jim Radford 2001-02-09 20:24:51 EST
You _almost_ got it. :-)  Try:

--- nfs-utils.spec~     Mon Feb  5 03:47:27 2001
+++ nfs-utils.spec      Fri Feb  9 16:23:26 2001
@@ -1,7 +1,7 @@
 Summary: NFS utlilities and supporting daemons for the kernel NFS server.
 Name: nfs-utils
 Version: 0.2.1
-Release: 8
+Release: 8netgroup
 Source0: ftp://nfs.sourceforge.net/pub/nfs/nfs-utils-%{version}.tar.gz
 Source1: ftp://nfs.sourceforge.net/pub/nfs/nfs.doc.tar.gz
 Source10: nfs.init
@@ -50,7 +50,7 @@
 # Hack to enable netgroups.  If anybody knows the right way to do
 # this, please help yourself.
 #
-ac_cv_func_innetgr=yes
+ac_cv_func_innetgr=yes \
 CFLAGS="$RPM_OPT_FLAGS" ./configure --mandir=${RPM_BUILD_ROOT}%{_mandir}
 make all
Comment 2 Bob Matthews 2001-02-12 13:09:47 EST
*** Bug 23849 has been marked as a duplicate of this bug. ***
Comment 3 Bob Matthews 2001-02-12 13:10:39 EST
Thanks for the patch!  Fixed

Note You need to log in before you can comment on or make changes to this bug.