Bug 234433 - Broken multi-lib dependency in FC6 update
Broken multi-lib dependency in FC6 update
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: opal (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-29 03:08 EDT by Michael Schwendt
Modified: 2013-01-09 23:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-15 05:42:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2007-03-29 03:08:26 EDT
source rpm: opal-2.2.5-1.fc6.src.rpm
package: opal-devel - 2.2.5-1.fc6.i386 from fedora-core-updates-6-x86_64
  unresolved deps: 
     libopal_linux_x86_r.so.2.2

opal.i386 is not available for x86_64.
Comment 1 Daniel Veillard 2007-03-29 04:10:53 EDT
Sorry I don't understand that report, what is the problem exactly ?
I think we desactivated building ekiga and its specific libraries 
(opal and pwlib) i386 for x86_64, that occured before RHEL5 was
finalized at the beginning of the year could be related but I'm
not sure what you tried to do.

Daniel
Comment 2 Michael Schwendt 2007-03-29 04:35:06 EDT
See bug 230194 - in particular bug 230194 comment 13.
Comment 3 Daniel Veillard 2007-07-13 09:54:22 EDT
I still don't understand what you did and how it failed.
opal and pwlib should not be multi-lib as they are used only
of Ekiga and not for anything else. If they were multi-lib in
the past that was a mistake, but it's hard to fix retrospectively.

Daniel
Comment 4 Michael Schwendt 2007-07-15 05:42:08 EDT
There's opal-devel.i386, but not opal.i386 in the x86_64 repo:
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/6/x86_64/

Since you say it's too hard to fix that, closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.