Bug 234458 - JIS2004 support in Pango
JIS2004 support in Pango
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pango (Show other bugs)
5.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
: i18n
Depends On:
Blocks: 434466
  Show dependency treegraph
 
Reported: 2007-03-29 09:15 EDT by Akira TAGOH
Modified: 2013-01-10 16:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-08 15:31:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2007-03-29 09:15:29 EDT
Description of problem:
I'm not sure if freetype or HarfBuzz supports to reflect the feature tags to
GSUB/GPOS tables, which is defined in OpenType Layout tag registry, but that
feature is required to support JIS2004 and the way to switch them in Pango as well.
Speaking of particular requirements, it is 'jp04' feature tag

http://www.microsoft.com/typography/otspec/features_fj.htm#jp04

Also, I suppose applications may needs to support toggling feature. we may want
to clone this bug to the proper components then.
Comment 1 Behdad Esfahbod 2007-04-02 14:08:15 EDT
This needs some major work in Pango.  HarfBuzz supports all needed features for
this.  Please file upstream with as much information as you can provide.  That
is, which fonts to test this with, current and expected output, and how should
this feature be trigerred?  Under a certain locale?  etc...
Comment 2 Akira TAGOH 2007-04-02 19:52:05 EDT
Sure.  As we talked on IRC, I don't think we can provide a certain font to check
for this, because no free JIS2004 fonts are available so far. and AFAIK that
Ricoh fonts and the fonts in Vista does support this right now.

So I'll try to make a test font having this feature and open a bug on upstream then.
Comment 3 Akira TAGOH 2007-04-09 01:01:52 EDT
After some investigation how Vista supports JIS2004 in their fonts, I see they
actually don't use jp04 feature tag anywhere.  Their fonts has already been
based on JIS2004 and there seems to be jp90 feature tag to switch back them to
JIS90-wise. which is actually undocumented behavior..
Comment 4 RHEL Product and Program Management 2007-04-25 16:16:58 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Behdad Esfahbod 2007-04-25 21:08:53 EDT
I don't see this feature in 5.1 timeframe.
Comment 6 Matthias Clasen 2007-06-08 15:28:48 EDT
Set dev-nack based on Behdads latest comment
Comment 7 RHEL Product and Program Management 2007-06-08 15:31:19 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.