Bug 23451 - Root-RAID1 + devfs install bug
Root-RAID1 + devfs install bug
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-05 18:50 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-05 18:50:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-05 18:50:48 EST
Hello,

It seems to be impossible to install lilo from a running linux with
2.4+devfs on the MBRs, configuration that I'm currently running but without
devfs.

Take my config as an example:

boot=/dev/md0
map=/boot/map
install=/boot/boot.b
....
image=/boot/vmlinuz-2.4.0
...
        root=/dev/md0

The problem is that if you specify boot=/dev/md0, lilo installs the boot
records in the partition boot records and not in the master boot. This is
beacause lilo asks via a ioctl to the md driver what are the devices
contanining the RAID and the md driver correctly responds /dev/hda1 and
/dev/hdd1. 

Casually, lilo shipped with redhat cuts the device name to  8 characters,
using /dev/hda where it should have used /dev/hda1 and so, without devfs,
lilo installs correctly.

When devfs is used, lilo couldn't install anymore:

[root@monitor lilo-21.6.1]# lilo
boot = /dev/hda1, map = /boot/map.0301
Added linux *
boot = /dev/ide/host0/bus1/target1/lun0/part1, map = /boot/map.1641
Added linux *

As you see, lilo is installed in hda1 and hdd1.

As a quick workaround, I modified lilo to subtract 1 from the device number
reported from md, using hda instead of hda1 and it installed correctly.

So, the question is: Should lilo use the master boot or the partition boot
sector when installing on a RAID1 set ? In either cases, something has to
be fixed.
Comment 1 Jeremy Katz 2002-06-04 02:11:27 EDT
We do not support the use of devfs on Red Hat Linux systems.  Installing to
software RAID without the use of devfs works fine

Note You need to log in before you can comment on or make changes to this bug.