Bug 234551 - FC7 test3 CD/DVD install images hang at bootloader screen
FC7 test3 CD/DVD install images hang at bootloader screen
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-29 22:41 EDT by David Miller
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-09 13:15:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Miller 2007-03-29 22:41:25 EDT
Description of problem:

All of Live CD, KDE Live CD, and Prime DVD hang at the initial
bootloader screen.  This is on a Dell Dimension E520, dual-core
Pentium D, 1GB ram.

Version-Release number of selected component (if applicable):

How reproducible:

Every time.

Steps to Reproduce:
1. Insert CDROM/DVD
2. boot
3.
  
Actual results:

Bootloader screen displays, then machine completely hangs.

Expected results:

System boots and installer starts.

Additional info:
Comment 1 David Miller 2007-03-29 22:44:09 EDT
I just tried the Live CD on my Thinkpad T42p and it worked there
and did not hang.
Comment 2 David Miller 2007-03-29 23:50:04 EDT
More information, FC7 test2 live CD fails in the same way on the Dell
as test3.

FC6 and RHEL5 install properly and do not hang at the DVD bootloader
screen on this system.
Comment 3 David Miller 2007-03-30 02:44:51 EDT
More information, FC7 test1 CD boots properly.

So whatever changed between test1 and test2 introduced the problem.
Comment 4 Florian La Roche 2007-04-03 06:14:35 EDT
Syslinux upstream has added the following patch into the 3.3x branch:
http://www.jur-linux.org/git/?p=syslinux.git;a=commitdiff;h=c7c51cdcd0a094c2588f8a816542bc57bb4efb34

I'm adding that into the FC-development rpm, so this
should be in tomorrows rawhide push,
greetings,

Florian La Roche
Comment 5 Matthew Miller 2007-04-06 16:24:22 EDT
This isn't obvious anywhere, but Fedora 7 test bugs should be filed against the
"devel" version.
Comment 6 David Miller 2007-04-06 20:15:45 EDT
Thanks.  I can't tell you how much time I spent trying to figure that
out, none of the fedora wiki, nor bug reporting pages, nor FC7 test
release notes gave any direction in this area.
Comment 7 David Miller 2007-04-27 17:51:35 EDT
Test4 still has this bug.  So the patch from comment #4
doesn't fix the problem.
Comment 8 Steve 2007-05-07 06:33:42 EDT
I've the same problen here with an asus board. The DVD starts, is loading the
kernel and the system hangs with the message "Ready". The installer starts if i
unplug the sata-drive!
Comment 9 Steve 2007-05-07 10:04:31 EDT
I've forgot to say:
Both, F-6.93-i386-DVD.iso & F-6.93-i386-Live.iso have this problems. There are
no problem when no sata-drives are connectet. Also no problem with pata-drives.
Comment 10 Matt Domsch 2007-05-07 11:48:56 EDT
Adding Dell folks.
Comment 11 Peter Jones 2007-05-07 12:34:17 EDT
davem and I have been trying to isolate the problem via email and irc.  Using
newer syslinux, it appears the machine is not wedged -- with -2.fc7 the
countdown timer works.

What what we're seeing is a failure in the menus with either 'menu' or
'vesamenu'.  If "prompt 1" is set, you get "boot:" correctly, and keyboard input
works fine.  So the problem could be keyboard input in menu mode, or it could be
updating the screen, etc.  (Dave, refresh my memory here - does the timeout keep
counting down if you hit a key in menu mode?)
Comment 12 David Miller 2007-05-07 18:43:14 EDT
The person in comments #8 and #9 is seeing a totally different bug.
That problem appears to be in the kernel, whereas the issue covering
this bugzilla has to do with the bootloader long before the kernel
is even loaded.

In response to Peter's comment #11, yes the counter keeps going down
even if I tap some keys and eventually the kernel boots when the
timer expires.
Comment 13 Peter Jones 2007-05-08 10:48:17 EDT
OK, so Jes has this happening on another Dell (A Woodcrest) with 4G of ram, and
I can reproduce it on an Intel SDV with 4G as well.  Any chance you've got 4G of
ram, Dave?  And if so, does it work with 2G?
Comment 14 Peter Jones 2007-05-08 10:51:34 EDT
I retract the bit about the SDV.  I had unplugged the keyboard I normally use
while trying to reproduce this with a USB kbd yesterday.  Works fine on the SDV
if your keyboard is plugged in.
Comment 15 Steve 2007-05-08 10:57:36 EDT
(In reply to comment #12)
> The person in comments #8 and #9 is seeing a totally different bug.
> That problem appears to be in the kernel, whereas the issue covering
> this bugzilla has to do with the bootloader long before the kernel
> is even loaded.

Should I open a new bug report for that?

Comment 16 Jes Sorensen 2007-05-08 11:04:18 EDT
Hi,

I was seeing the same problem on FC7test4 on a Dimension 490 Woodcrest
bug. Peter Jones provided me a modified boot image and I was able to
get it going.

However, the USB keyboard is not recognized in the boot loader, but
plugging in a PS/2 one did work. Not sure whats at fault here, but
the USB one worked fine once getting to the real installer gui.

Jes
Comment 17 Peter Jones 2007-05-08 11:54:42 EDT
(The modified boot.iso provided to Jes was the one with just the countdown timer
fixed, FWIW)
Comment 18 David Miller 2007-05-08 14:24:17 EDT
My machine has less than 4GB of ram, I think ram size is a red herring.

I think we need to keep digging at the keyboard intcall stuff in
the com32 code of syslinux.
Comment 19 Peter Jones 2007-05-09 10:25:35 EDT
I think you're right about the intcall stuff.  I suspect Jes has usb emulation
turned off and was just seeing the other (timeout) bug.  On Dell systems USB
emulation winds up being turned on while BIOS is running whether it's actually
enabled or not, so there's no way to tell without him checking.
Comment 20 Peter Jones 2007-05-09 10:27:28 EDT
You know, it'd be interesting to know if this happens with pxelinux as well --
and if it does, we can do a much simpler test case that doesn't require building
ISO images.  Dave, I'll send you an email with details on how to set up such a
test case.
Comment 21 Peter Jones 2007-05-09 13:15:32 EDT
The guys from Dell say:
> It looks like we have a test BIOS in house (not yet released) that fixes
> this issue.  I've reproduced the issue (with FC7 test3 DVD), and
> verified that the new BIOS fixes the issue.
>
> I don't have a very good description of the root cause right now, other
> than this broke when a different problem was fixed, so presumably an
> older rev of the BIOS might also work.

and:
> Current BIOS version for Dimension e520 is 2.3.2. If you back it up
> three versions back  to v.2.2.0, the problem should get fixed.

So it looks like this is a BIOS bug, and I'm going to close this BZ.  Feel free
to reopen it if the need arises.

Note You need to log in before you can comment on or make changes to this bug.