Bug 234671 - KDE desktop menu produces artifacts
KDE desktop menu produces artifacts
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-30 19:25 EDT by Mark Bidewell
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 11:32:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of Issue (755.79 KB, image/png)
2007-04-11 21:16 EDT, Mark Bidewell
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 142628 None None None Never

  None (edit)
Description Mark Bidewell 2007-03-30 19:25:55 EDT
When I right click on desktop and then click off the menu, there is often a
black hole on the desktop where the menu was.  This does not occur with GNOME or
XFCE.  The problem also occurs on FC6 with the latest updates.  I have a Nvidia
GeForce FX6200 video card with an Envision en2028 monitor attached via DVI (the
problem also occurs with the analog port).  There is no difference between the
nv and nvidia drivers.

The issue would appear to be in the kdesktop app since running kdesktop from a
failsafe login exhibits the behavior.

Finally, I initially submitted this to the upstream KDE project, believing the
problem to be there, but I have not been able to replicate the problem using the
Kubuntu live CD ( which features KDE 3.5.6 ), or Knoppix.  Knoppix however used
KDE 3.5.5 which I do not belive exhibited this behavior.  Based on this
research, I have to conclude that this is a fedora issue, and I labeled the KDE
issue as resolved.

One other data point.  I have FC6 installed on a Dell B130 laptop with intel
graphics.  This system does not exhibit any problems.
Comment 1 Mark Bidewell 2007-04-01 15:45:48 EDT
When I tried with F7T3 I used the live-cd so the was no outside software
interaction.
Comment 2 Mark Bidewell 2007-04-06 21:54:46 EDT
As another data point.  I tried OpenSuse 10.2 updated to KDE 3.5.6.  There were
no issues with kdesktop.
Comment 3 Matthew Miller 2007-04-10 12:31:31 EDT
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.
Comment 4 Ngo Than 2007-04-10 12:57:51 EDT
could you please attach a screenshot? Thanks

i'm not able to reproduce this problem on my test machine
Comment 5 Mark Bidewell 2007-04-10 13:27:40 EDT
Thanks for moving this to the appropriate list.  It has been listed as NEEDINFO.

What information is required?
Comment 6 Ngo Than 2007-04-11 09:35:41 EDT
could you please attach a screenshot? Thanks

i'm not able to reproduce this problem on my test machine
Comment 7 Mark Bidewell 2007-04-11 21:16:09 EDT
Created attachment 152332 [details]
Screenshot of Issue

Here is a screenshot of the problem.  The ragged edges are caused by a window
passing over the area and redrawing the area properly.

I have been using OpenSUSE since 4/6 and have not seen any issues. with 3.5.6.
Comment 8 Mark Bidewell 2007-04-13 17:10:38 EDT
Do you think trying the GNOME FC7 live cd could produce any helpful information?
Comment 9 Mark Bidewell 2007-04-15 19:07:02 EDT
I neglected to mention one other point.  I only get the behavior when the menu
is dismissed without selecting an option.
Comment 10 Mark Bidewell 2007-04-27 19:03:31 EDT
I just evaluated F7T4 and the problem is still present although much harder to
reproduce than previously,
Comment 11 Rex Dieter 2007-05-24 10:17:32 EDT
Unable to reproduce either (using native/oss ati/intel drivers).  I may be going
out on a limb here, but would venture this more likely to be a video
hardware/driver issues, rather than a kde one.
Comment 12 Mark Bidewell 2007-05-24 10:29:33 EDT
(In reply to comment #11)
> Unable to reproduce either (using native/oss ati/intel drivers).  I may be 
going
> out on a limb here, but would venture this more likely to be a video
> hardware/driver issues, rather than a kde one.

That was my initial thought as well (and I realize that 8600GTS is not 
supported by stable drivers yet).  But how could a hardware/driver issue affect 
only one distro/DE?  I used the same NVIDIA driver on openSUSE and Fedora.  I 
believe Xorg is the same version on both as well.  I'm not very familiar with 
this but could AIGLX vs Compiz have anything to do with this.

Is there anything else I could try to help narrow this down?

Thanks.
Comment 13 Rex Dieter 2007-05-24 10:34:27 EDT
> I'm not very familiar with  this but could AIGLX vs Compiz have anything to do 
> with this.

Most certainly could, if you were using it (compiz).  Are/were you?
Comment 14 Mark Bidewell 2007-05-24 10:48:20 EDT
Sorry I meant Xgl not compiz :(.  What I was wondering was if that could make a 
difference Fedora uses AIGLX whereas openSUSE and (I believe) (K)Ubuntu use 
Xgl. This is a shot in the dark however as I don't believe I used either.

For the record here, I have seen this on two systems:
-AMD Athlon XP 2500 Asus A8nx MB Geforce FX6200
-Intel core 2 duo intel DG965WH MB 8600GTS

Comment 15 Mark Bidewell 2007-05-24 19:05:00 EDT
Another interesting datapoint.  the DG965WH has an integrated graphics card
which I just tried.  I was able to reproduce the problem with the intel graphics
(the nvidia card was still installed) using the vesa driver and AIGLX disabled.
 It seems strange that this problem cannot be reproduced.  Any debugging
suggestions? The problem seems to occur at any resolution.
Comment 16 Rex Dieter 2007-05-24 19:07:41 EDT
With that chipset, you should be able to use the 'intel' driver (with dri). ??
Comment 17 Mark Bidewell 2007-05-24 23:00:30 EDT
I did(In reply to comment #16)
> With that chipset, you should be able to use the 'intel' driver (with dri). ??

I didn't try that. However, for kicks I installed KDE 3.5.6 with the kde-redhat
repo enabled as opposed to just extras.  Problem solved.  I have not had a
problem since.  What is the difference between the kdebase in extras and the one
from kde-redhat?
Comment 18 Rex Dieter 2007-05-25 08:07:45 EDT
Interesting, glad to hear your good news.
Unfortunately, these days, the differences (in kdebase anyway) are negligible.
Comment 19 Mark Bidewell 2007-05-25 08:26:57 EDT
(In reply to comment #18)
> Interesting, glad to hear your good news.
> Unfortunately, these days, the differences (in kdebase anyway) are negligible.

My guess would be a compile option(s) is the issue, I will try to look at the 
spec files, but I am no RPM expert. I think the problem began when kdebase (I 
guess this package is the issue as kdesktop is the only problem app) was 
introduced into extras and overwrote the kde-redhat package on an update. Two 
other questions:

1) does extras backport any patches/code for KDE?
2) will kde-redhat be supplying RPMs for FC7 or will everything be merged into 
extras?

Thanks and is there anything I can check to track this down further?
Comment 20 Rex Dieter 2007-05-25 08:42:56 EDT
> 1) does extras backport any patches/code for KDE?

not sure what you mean here exactly, since there is no longer any distinction
between core/extras, it's all fedora now... so I think the answer is you're
looking for is "yes". :)

> 2) will kde-redhat be supplying RPMs for FC7 or will everything be merged...?

In general the latter (where possible).  kde-redhat can/will still be a
potential playground for experimental features, however. 
Comment 21 Mark Bidewell 2007-05-25 08:59:12 EDT
(In reply to comment #20)
> > 1) does extras backport any patches/code for KDE?
> not sure what you mean here exactly, since there is no longer any distinction
> between core/extras, it's all fedora now... so I think the answer is you're
> looking for is "yes". :)

The problem being that FC7 exhibits the above bad behavior :(.  What I am doing 
is searching for the reason why kde-redhat kdebase renders properly but extras 
does not.  The only logical reasons I could see are a slightly different 
codebase and/or compile options and/or default settings and/or dependencies.  
Unfortunately thats about everything.  I'm really at a loss to know where to 
begin looking. Any suggestions?
Comment 22 Mark Bidewell 2007-05-25 09:19:51 EDT
Not do deluge this thread, but it it worthwhile at this point to debug 3.5.6 or 
wait and see if the problem is still present on 3.5.7?
Comment 23 Rex Dieter 2007-05-25 09:26:12 EDT
3.5.7 is being worked on, so let's take a wait-n-see approach (for now).
Comment 24 Mark Bidewell 2007-06-01 11:29:02 EDT
A final datapoint before waiting for 3.5.7. 

1) F7 final exhibits the rendering flaw
2)  The last kdelibs update for FC6 - when I saw it I tried removing kde and 
reinstalling from pure extraa (no kde-redhat).  There were no problems with 
rendering.  Either the kde-redhat kdebase(libs) changes a setting which fixes 
this issue and does not remove it on an uninstall, or that last kdelibs update 
fixed the bug.
Comment 25 Mark Bidewell 2007-06-11 11:32:45 EDT
This bug seems to have dropped off the face of the earth (YAY!!) - although I 
with I knew why, I did an initial F7 install from the KDE live cd and had 
problems, so I installed from the prime CD and installed KDE later from repos ( 
I also switched to x86_64)  So I will mark it as resolved.  BTW what is the 
best way to stay abrest of developments with Fedora and KDE?
Comment 26 Rex Dieter 2007-06-11 11:42:21 EDT
> what is the best way to stay abrest of developments with Fedora and KDE?

Join/participate-in the KDE SIG, 
http://fedoraproject.org/wiki/SIGs/KDE
we'd love to hear from any interested folks.
Comment 27 Mark Bidewell 2007-06-11 12:02:47 EDT
Thanks, what mailing lists should I join fedora-desktop and fedora-devel?
Comment 28 Rex Dieter 2007-06-11 12:06:44 EDT
Both of those would be a good start, yes.
Comment 29 Mark Bidewell 2007-06-25 10:58:24 EDT
I realize that this has been resolved but I was finally able to track down the 
cause (I believe) of this problem.  The problem disappears when xorg is 
properly configured for compiz/beryl and appears when it is not.  I also had 
difficulty using livna rpms.  The Nvidia installer worked better, however I 
belive this might be related more to xorg.conf options than to packaging.
Comment 30 Rex Dieter 2007-06-25 11:11:54 EDT
I think we can agree this is no kde bug, but rather some combination of
compiz/beryl/Xgl + non-free/oss DRI/GL xorg drivers (likely more of the latter).

Note You need to log in before you can comment on or make changes to this bug.