Bug 23472 - Anaconda Fails after Packages are installed
Summary: Anaconda Fails after Packages are installed
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-06 04:50 UTC by Jonathan
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-10 01:08:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump from Anaconda Error (792 bytes, text/plain)
2001-01-06 04:50 UTC, Jonathan
no flags Details

Description Jonathan 2001-01-06 04:50:10 UTC
I am attempting to install RH70 on a PII 350 Machine with 128MB RAM.  
Anaconda fails on both this computer and My gateway solo 2150 laptop when 
the Packages are finished installing.  I get this error:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
  File "/tmp/updates/todo.py", line 1638, in doInstall
    self.createCdrom()
  File "/tmp/updates/todo.py", line 1189, in createCdrom
    os.symlink(device, self.instPath + "/dev/" + cdname)
OSError: [Errno 28] No space left on device


Local variables in innermost frame:
device: hdc
list: ['hdc']
self: <todo.ToDo instance at 81bf358>
cdname: cdrom
count: 1
ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I0
sS'fnames'
p9
(dp10
<failed>

 I think that the error is incorrect since I have a 6 GB HD that isn't out 
of space whatsoever  HELP

Comment 1 Jonathan 2001-01-06 04:50:45 UTC
Created attachment 7124 [details]
Dump from Anaconda Error

Comment 2 Michael Fulbright 2001-01-09 21:33:33 UTC
How much space did you allocate for your '/' partition?

Comment 3 Jonathan 2001-01-10 01:08:38 UTC
58MB as was directed in Red Hat Linux for Dummies 3rd Ed.

Comment 4 Michael Fulbright 2001-01-26 22:18:09 UTC
I would recommend no less than 150M for the / partition.


Note You need to log in before you can comment on or make changes to this bug.