Bug 234741 - Multilib conflict (upgrade path): /usr/share/hal/fdi/*
Multilib conflict (upgrade path): /usr/share/hal/fdi/*
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-01 05:56 EDT by Saikat Guha
Modified: 2013-03-05 22:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-01 06:05:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saikat Guha 2007-04-01 05:56:01 EDT
Transaction Check Error:
  file /usr/share/hal/fdi/fdi.dtd from install of hal-0.5.9-0.git20070326.fc7
conflicts with file from package hal-0.5.9-0.git20070304.fc7
  file /usr/share/hal/fdi/information/10freedesktop/10-usb-music-players.fdi
from install of hal-0.5.9-0.git20070326.fc7 conflicts with file from package
hal-0.5.9-0.git20070304.fc7
  file /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-acer.fdi
from install of hal-0.5.9-0.git20070326.fc7 conflicts with file from package
hal-0.5.9-0.git20070304.fc7
  file /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-apple.fdi
from install of hal-0.5.9-0.git20070326.fc7 conflicts with file from package
hal-0.5.9-0.git20070304.fc7
  file /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-asus.fdi
from install of hal-0.5.9-0.git20070326.fc7 conflicts with file from package
hal-0.5.9-0.git20070304.fc7
  file /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-dell.fdi
from install of hal-0.5.9-0.git20070326.fc7 conflicts with file from package
hal-0.5.9-0.git20070304.fc7
  file
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-fujitsu.fdi from
install of hal-0.5.9-0.git20070326.fc7 conflicts with file from package
hal-0.5.9-0.git20070304.fc7
  file /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-hp.fdi
from install of hal-0.5.9-0.git20070326.fc7 conflicts with file from package
hal-0.5.9-0.git20070304.fc7
  file /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-ibm.fdi
from install of hal-0.5.9-0.git20070326.fc7 conflicts with file from package
hal-0.5.9-0.git20070304.fc7
  file /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-misc.fdi
from install of hal-0.5.9-0.git20070326.fc7 conflicts with file from package
hal-0.5.9-0.git20070304.fc7
  file /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-sony.fdi
from install of hal-0.5.9-0.git20070326.fc7 conflicts with file from package
hal-0.5.9-0.git20070304.fc7
  file
/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-toshiba.fdi from
install of hal-0.5.9-0.git20070326.fc7 conflicts with file from package
hal-0.5.9-0.git20070304.fc7
  file /usr/share/hal/fdi/policy/10osvendor/10-power-mgmt-policy.fdi from
install of hal-0.5.9-0.git20070326.fc7 conflicts with file from package
hal-0.5.9-0.git20070304.fc7
  file /usr/share/hal/fdi/policy/10osvendor/20-acl-management.fdi from install
of hal-0.5.9-0.git20070326.fc7 conflicts with file from package
hal-0.5.9-0.git20070304.fc7




[root@sioux SPECS]# rpm -q hal
hal-0.5.9-0.git20070304.fc7.x86_64
hal-0.5.9-0.git20070304.fc7.i386
Comment 1 Saikat Guha 2007-04-01 06:05:59 EDT
Whoops. The exclude i?86 line was not commented out in yum.conf so yum couldn't
upgrade the i386 version of the package when it was upgrading the x86_64 version
causing the problem.

Commenting out the exclude line in yum.conf resolves this problem.

Note You need to log in before you can comment on or make changes to this bug.