Bug 234795 - alsa-lib 1.0.14 broke things
alsa-lib 1.0.14 broke things
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-02 00:17 EDT by Darren Cook
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 03:38:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of system-config-soundcard (13.46 KB, text/plain)
2007-04-02 00:17 EDT, Darren Cook
no flags Details

  None (edit)
Description Darren Cook 2007-04-02 00:17:50 EDT
Description of problem:

I upgraded to alsa-lib 1.0.14 (from 1.0.11 as far as I know).
xmss complained it couldn't find soundcard. So in properties I changed the audio
device from "hw:0,0" to "default". It then played, but very quietly (full volume
was roughly as loud as the previous 30% level).
Then when I tried gtick, which is set to use /dev/audio, it did not work. I
tried some other guesses, but nothing else worked.
Tried changing permissions of /dev/audio (was 600) to 666 and 777 but no luck.

Tried going back to an earlier kernel (from 2307 to 2200). No difference.

Then, with kernel back to 2307, and /dev/audio permissions back to defaults,
tried going back to version 1.0.11 of alsa-lib and alsa-lib-devel.

Neither xmss (any audio device) nor gtick (/dev/audio) produce any sound.

Moved back to 1.0.14. xmss and gtick continue to produce no sound.
Tried system-config-soundcard. It made no noise whichever of the three audio
devices.

Summary: it used to work fine before upgrading to 1.0.14. After upgrading it
half-worked. After downgrading and upgrading nothing works.


Additional info:
scsound.log is attached, showing clicking play for each of three available PCM
devices, then again with "disable software mixing" checked.
Comment 1 Darren Cook 2007-04-02 00:17:50 EDT
Created attachment 151402 [details]
Output of system-config-soundcard
Comment 2 Darren Cook 2007-04-02 03:38:58 EDT
Rebooting fixed this (i.e. I am using 1.0.14 and xmss and /dev/audio work).
Sorry for the noise. For anyone who finds this, makes sure you you reboot each
time you change alsa RPMs, as they seem to be intricately linked with the kernel
and the boot process. (It'd be nice if the RPM post-install step could suggest
this.)

If you've upgraded to 1.0.14 and have the same symptoms as me (sound is quiet,
/dev/audio not working) I suggest first trying: remove alsa and alsa-devel (use
--nodeps), then mv /etc/alsa out of the way to make sure you get a fresh copy,
then reinstall 1.0.14, then reboot.

Note You need to log in before you can comment on or make changes to this bug.