Bug 235039 - conditionalized flush causes clear region requests to remain unflushed
conditionalized flush causes clear region requests to remain unflushed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Earl Brassow
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-03 11:00 EDT by Jonathan Earl Brassow
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 14:45:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Earl Brassow 2007-04-03 11:00:51 EDT
If you suspend/dtr a mirror, clear region requests are not flushed to disk. 
This means that the next time a cluster mirror is started, those regions will be
incorrectly assumed to be not in-sync.

The culprit is in rh_update_states:
        if (!list_empty(&recovered))
                rh->log->type->flush(rh->log);

The conditional should be removed.  Note that this does not cause extra disk
activity, since the (disk) log checks for lc->touched.
Comment 1 Jonathan Earl Brassow 2007-04-05 12:08:20 EDT
patch posted to dm-devel

https://www.redhat.com/archives/dm-devel/2007-April/msg00002.html
Comment 2 Jonathan Earl Brassow 2007-05-08 14:23:26 EDT
assigned -> post
Comment 3 RHEL Product and Program Management 2007-05-08 14:42:29 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 4 Don Zickus 2007-06-15 20:33:38 EDT
in 2.6.18-27.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 7 errata-xmlrpc 2007-11-07 14:45:55 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html

Note You need to log in before you can comment on or make changes to this bug.