Bug 235081 - LTC29076-multipath -ll option hangs after quiesce of a pav enabled dasd
LTC29076-multipath -ll option hangs after quiesce of a pav enabled dasd
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.0
All Linux
high Severity high
: ---
: ---
Assigned To: Ben Marzinski
Corey Marthaler
: OtherQA
Depends On: 214838
Blocks: 234251
  Show dependency treegraph
 
Reported: 2007-04-03 14:19 EDT by Josef Bacik
Modified: 2010-10-22 10:10 EDT (History)
12 users (show)

See Also:
Fixed In Version: RHEA-2007-0808
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:16:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Josef Bacik 2007-04-03 14:20:25 EDT
cloned for rhel4, customer is reporting the issue is in rhel4 as well.
Comment 2 RHEL Product and Program Management 2007-05-09 01:03:51 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Ben Marzinski 2007-07-26 15:28:07 EDT
Ported and applied.
Comment 5 John Poelstra 2007-08-29 13:28:09 EDT
A fix for this issue should have been included in the packages contained in the
RHEL4.6 Beta released on RHN (also available at partners.redhat.com).  

Requested action: Please verify that your issue is fixed to ensure that it is
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 6 John Poelstra 2007-09-05 18:25:07 EDT
A fix for this issue should have been included in the packages contained in 
the RHEL4.6-Snapshot1 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed to ensure that it is 
included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed, 
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent 
symptoms of the problem you are having and change the status of the bug to 
FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test 
results to Issue Tracker.  If you need assistance accessing 
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 7 John Poelstra 2007-09-11 20:39:47 EDT
A fix for this issue should be included in RHEL4.6-Snapshot2--available soon on
partners.redhat.com.  

Please verify that your issue is fixed to ensure that it is included in this
update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test
results to Issue Tracker.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 8 IBM Bug Proxy 2007-09-18 04:56:27 EDT
Comments from the bug submitter. Changing the status to FAILS_QA.
=========================================
Hi ,

RHEL4.6snap2
I dont see any difference in output , multipath -ll still hangs .

[root@t2930012 home]# qui /dev/dasdc
Trying QUIESCUE on /dev/dasdc...
Done.
[root@t2930012 home]# multipath -l
mpath1 (0X2AAA)
[size=2 GB][features="0"][hwhandler="0"]
\_ round-robin 0 [active]
 \_ 0:0:10921:0 dasdc 94:8  [active]
 \_ 0:0:10780:0 dasdd 94:12 [active]
 \_ 0:0:10922:0 dasde 94:16 [active]
 \_ 0:0:10923:0 dasdf 94:20 [active]

[root@t2930012 home]# multipath -ll----------------->session hanged

[root@t2930012 ~]# multipathd -k
multipathd> show paths

0:0:10921:0 dasdc 94:8  1 [failed][faulty] X.... 1/5
0:0:10780:0 dasdd 94:12 1 [active][ready] XXXXXXXXXXXXXXX..... 15/20
0:0:10922:0 dasde 94:16 1 [active][ready] XXXXXXXXXXXXXXX..... 15/20
0:0:10923:0 dasdf 94:20 1 [active][ready] XXXXXXXXXXXXXXX..... 15/20

Thanks 
priya
========================================
Comment 9 Jay Turner 2007-09-18 07:06:28 EDT
Moving to Assigned so it pops up on developer's radar.
Comment 11 Ben Marzinski 2007-09-18 14:36:38 EDT
Please see bz #214838

The subject line for this bug was misleading. The real problem is that
multipathd hangs when this happens. This halts your path checking until the
quiesce completes.

The problem is that when you run multipath -ll, you are explicitly asking
multipath to check the device.  The kernel will not allow a process to exit
until any outstanding IO that it initiates gets completed or failed. multipathd
works fine with this change because it is not exitting after it checks the
device. To make multipath not hang, it would need to send all of it's requests
to multipathd instead, if multipathd is running. This is a major code change
that will not happen for RHEL 5.1

You can avoid having multipath hanging by running

# multipath -l

instead of

# multipath -ll

The difference is that multipath -l doesn't run the path checker. It just lists
the kernels view of the status, which is almost always the same as the path checker.

Can you please verify that multipathd no longer hangs with thic change.
Comment 12 John Poelstra 2007-09-20 00:29:07 EDT
A fix for this issue should have been included in the packages contained in the
RHEL4.6-Snapshot3 on partners.redhat.com.  

Please verify that your issue is fixed to ensure that it is included in this
update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message about your test
results to Issue Tracker.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 13 Issue Tracker 2007-09-25 09:37:02 EDT
----- Additional Comments From priyamunshi@in.ibm.com  2007-09-25 05:15 EDT
-------
Hello,
 Rhel4.6snap2
Multipathd no longer hangs , and multipath -l shows the paths.

Thanks
priya 


This event sent from IssueTracker by jkachuck 
 issue 117047
Comment 15 errata-xmlrpc 2007-11-15 11:16:00 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0808.html

Note You need to log in before you can comment on or make changes to this bug.