Bug 235159 - update version of sg3_utils
update version of sg3_utils
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sg3_utils (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-04 00:14 EDT by Ben Levenson
Modified: 2015-03-04 20:18 EST (History)
2 users (show)

See Also:
Fixed In Version: RHEA-2008-0468
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:48:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2007-04-04 00:14:36 EDT
Description of problem:
RHEL-4.5 has version 1.22. RHEL-5-GA has version 1.20.  We should consider
bumping the version in RHEL-5.
Comment 1 Rob Kenna 2007-06-05 10:52:10 EDT
Unlikely to get updated since it's not in the package budget already.  Is there
anything key that's needed here?
Comment 2 Ben Levenson 2007-08-14 00:06:18 EDT
I filed this bug to catch upgrade issues. As long as version 1.22 (RHEL-4.5) works
after an RHEL-4.5 -> RHEL-5.1 upgrade, then we should be fine.  I'll try to
verify this sometime this week.
Comment 3 James Laska 2007-08-14 10:42:26 EDT
Tested on a ppc installation after a RHEL-4.5 -> RHEL-5.1 upgrade

# grep sg3_utils install.log
Installing sg3_utils-libs-1.22-3.1.ppc.
Installing sg3_utils-1.22-3.1.ppc.
Installing sg3_utils-devel-1.22-3.1.ppc.
# grep sg3_utils upgrade.log

All of the sg3_util binaries appear to run without any obvious segfaults.  For
example: 

# sg_scan 
/dev/sg0: scsi0 channel=1 id=5 lun=0
/dev/sg1: scsi0 channel=1 id=8 lun=0
/dev/sg2: scsi0 channel=1 id=15 lun=0
/dev/sg3: scsi0 channel=255 id=255 lun=255
/dev/sg4: scsi2 channel=0 id=0 lun=0 [em]


Is there a more accurate test that could be performed to gauge the health of the
sg3_utils binaries?
Comment 4 Phil Knirsch 2007-08-15 09:06:08 EDT
IIRC sg3_utils isn't an approved component for RHEL-5.1, mind if we move that to
RHEL-5.2?

Read ya, Phil
Comment 5 Pete Graner 2007-08-23 15:47:44 EDT
Not an approved component per:

http://intranet.corp.redhat.com/ic/intranet/RHEL5U1ApprovedPackages.html/

Moving to 5.2 proposed.
Comment 6 Ben Levenson 2007-10-22 20:22:15 EDT
(In reply to comment #4)
> IIRC sg3_utils isn't an approved component for RHEL-5.1, mind if we move that to
> RHEL-5.2?

Looks like pgraner answered this question in comment #5. :)  (This comment
should cause the bugzilla to move out of NEEDINFO) 
Comment 11 errata-xmlrpc 2008-05-21 12:48:12 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0468.html

Note You need to log in before you can comment on or make changes to this bug.