Bug 235207 - No WPA with iwlwifi driver for Intel IPW3945abg wireless card.
No WPA with iwlwifi driver for Intel IPW3945abg wireless card.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-04 11:13 EDT by Gareth Morgan
Modified: 2007-11-30 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 14:47:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gareth Morgan 2007-04-04 11:13:23 EDT
Description of problem:
The iwlwifi driver for the Intel IPW3945ABG doesn't support WPA in
NetworkManager (not tried wpa-supplicant). The firmware for this driver is
provided by iwlwifi-firmware-2.14.1-4.src.rpm. I assume the wifi stack and
actual driver are withing the kernel rpm since I cannot find RPMs for either
(the same problem occurs for the kernel-2.6.20-1.3023.fc7.src.rpm and
kernel-2.6.20-1.3040.fc7.src.rpm kernels). I dropped to a command line at one
point and the message "iwlwifi: TODO: Look into long/short preamble change
handling" was being continuously written to the screen.


Version-Release number of selected component (if applicable):
2.14.1-4

How reproducible:


Steps to Reproduce:
1. Install the iwlwifi-firmware package
2. Activate NetworkManage in GNOME System->Administration->Services
3. Try to connect to a WPA-PSK network with TKIP encryption
  
Actual results:
Upon selection the 'Wireless Network Key Required' dialog pops up. It states the
network uses LEAP and requests a username and password. There is also a key
management field with the options "IEEE 802.1x" and "WPA-EAP". Since my network
has a pass key rather than a user name and password no further progress is
possible. I've tried entering my key into either and both fields and it has no
effect.


Expected results:
It offers WPA encryption and has a field for my PSK. Upon clicking the login
button the wireless gets connected.

Additional info:

This obviously uses the new in kernel IPW3945 driver. The old driver (with the
regulatory daemon) supported WPA. I'm not sure if this is a case of todo because
there was a lack of data at the iwlwifi projects site.
Comment 1 Matthew Miller 2007-04-10 12:26:54 EDT
Fedora 7 test bugs should be filed against "devel", not against test1/2/3. This
isn't obvious, I know. Moving this report so it isn't lost.

This is a bulk message -- I apologize if this was actually meant to be targeted
against a different release. If so, please fix or let me know. Thanks.
Comment 2 Bryan O'Sullivan 2007-04-12 02:44:36 EDT
Sort of a dup of bug 235347, which seems to have become the catch-all "iwlwifi
is borked" bug.
Comment 3 John W. Linville 2007-04-12 10:38:15 EDT
Many have reported success with WPA on kernels starting with 3056.  Have you 
tried the latest rawhide kernels?
Comment 4 Gareth Morgan 2007-04-12 20:15:29 EDT
I've just updated my Kernel to the 3059 version. NetworkManager now detects WPA
properly but refuses to accept my key. I skipped the 3056 altogether and
currently have 3045 and 3059 on my system.
Comment 5 Sertaç Ö. Yıldız 2007-04-15 03:48:42 EDT
With 2.6.20-1.3066.fc7PAE I can associate a WPA-PSK AP with iwlwifi. However
immediately I get:

BUG: warning at include/asm/dma-mapping.h:25/dma_map_single() (Not tainted)
 [<c04061e9>] show_trace_log_lvl+0x1a/0x2f
 [<c04067ad>] show_trace+0x12/0x14
 [<c0406828>] dump_stack+0x16/0x18
 [<f8fec8f1>] d_tx+0x80c/0xd96 [iwlwifi]
 [<f8f826c6>] __ieee80211_tx+0x20/0xec [mac80211]
 [<f8f84588>] ieee80211_master_start_xmit+0x410/0x50e [mac80211]
 [<c05b6fca>] dev_hard_start_xmit+0x1ce/0x22b
 [<c05c4aa2>] __qdisc_run+0xdb/0x195
 [<c05b7cfd>] net_tx_action+0xc2/0xeb
 [<c042d333>] __do_softirq+0x6f/0xe2
 [<c0407418>] do_softirq+0x61/0xd0
 [<c042d15e>] local_bh_enable_ip+0xb9/0xdf
 [<c0618e1d>] _spin_unlock_bh+0x25/0x28
 [<f8f90c86>] ieee80211_scan_completed+0xdf/0x109 [mac80211]
 [<f8f920d7>] ieee80211_sta_scan_work+0x63/0x199 [mac80211]
 [<c043648f>] run_workqueue+0x89/0x14e
 [<c0436ea5>] worker_thread+0xf8/0x124
 [<c043968b>] kthread+0xb3/0xdc
 [<c0405cd3>] kernel_thread_helper+0x7/0x10
 =======================
Comment 6 Gareth Morgan 2007-04-15 11:32:59 EDT
With the kernel who's source is provided by kernel-2.6.20-1.3069.fc7.src.rpm I
can now get WPA to connect but still cannot get access over the network. When I
dropped to the CLI I get the following three lines repeated continuously.

iwlwifi: No space for Tx
iwlwifi: Error sending RXON: ipw-queue-tx-hcmd failed: -28
iwlwifi: Error clearing ASSOC_MSK on current configuration (-28).

Every 30 seconds or so the error message
iwlwifi: Error setting non-tune configuration (-28).
appears.
Comment 7 Brenton D. Rothchild 2007-04-20 13:14:25 EDT
(In reply to comment #6)
> With the kernel who's source is provided by kernel-2.6.20-1.3069.fc7.src.rpm I
> can now get WPA to connect but still cannot get access over the network. When I
> dropped to the CLI I get the following three lines repeated continuously.
> 
> iwlwifi: No space for Tx
> iwlwifi: Error sending RXON: ipw-queue-tx-hcmd failed: -28
> iwlwifi: Error clearing ASSOC_MSK on current configuration (-28).
> 
> Every 30 seconds or so the error message
> iwlwifi: Error setting non-tune configuration (-28).
> appears.

I am getting the same messages under similar WPA conditions with
kernel-2.6.20-1.3094.fc7 (x86_64).

Is there any additional information I can provide?
Comment 8 John W. Linville 2007-04-25 14:47:24 EDT
Sertaç, I think you should use bug 236451 instead.

Gareth and Brenton, I think you should use bug 236828 instead.

I think the actual "no wpa" issues is resolved.  I'm going to close this, as 
the remaining issues seem to be with driver stability.

Note You need to log in before you can comment on or make changes to this bug.