Bug 235248 - SELinux: explicitly set i_ino on all creations in selinuxfs to avoid collisions with assignment ranges
SELinux: explicitly set i_ino on all creations in selinuxfs to avoid collisio...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Paris
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-04 13:56 EDT by Eric Paris
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-05 17:03:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Paris 2007-04-04 13:56:21 EDT
http://marc.info/?l=selinux&m=117570344809918&w=2

selinux fs uses set i_ino for most of its inodes.  The exceptions are
directories and those inside avc/*

since the i_ino for those is determined by a global counter it is possible they
will colide with the ranges specified for booleans or initial_sids

We need to explicitly set all i_ino in order to make sure collision isn't possible.

Note You need to log in before you can comment on or make changes to this bug.