Bug 23529 - RFE: move cut to /bin
RFE: move cut to /bin
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: textutils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-07 06:43 EST by Michael Redinger
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-07 14:22:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2001-01-07 06:43:30 EST
Many startup scripts used (some still do) cut. However,
as it is placed in /usr/bin, it can only be used for scripts
that are started after netfs (in case /usr is on a NFS
server).
Moving it to /bin would solve this problem.
Comment 1 Bill Nottingham 2001-01-07 13:08:14 EST
I don't see any that start before netfs, but I could be looking at the wrong
ones...
Comment 2 Michael Redinger 2001-01-07 14:21:59 EST
Hm, I'm not quite sure if there are any left in the current beta - I did
make quite a few bug reports during last beta and for 7.0. Will
have to check this again. Thought I found at least two, but I could
be wrong.
However, many startup scripts changed to using awk instead
because cut isn't  always available for init scripts. Comparing 
only the file sizes (11644 for cut vs. 157884 for awk in 7.0) I'd suppose
that cut would be the proper choice in many cases (actually many
used it and changed to awk - my fault, I did then file a bug report 
eg. against ipchains because it was using cut - should have filed 
it against cut beacuse it isn't in /bin, I suppose)
Comment 3 Bernhard Rosenkraenzer 2001-01-08 09:00:46 EST
It's moved to /bin in 2.0.11.

Note You need to log in before you can comment on or make changes to this bug.