Bug 235437 - Emacs support for mercurial, own installed dirs
Summary: Emacs support for mercurial, own installed dirs
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mercurial (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Neal Becker
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: bzcl34nup
Keywords: Patch, Reopened
: 245359 (view as bug list)
Depends On:
Blocks: 438857
TreeView+ depends on / blocked
 
Reported: 2007-04-05 19:04 UTC by Ville Skyttä
Modified: 2008-04-12 13:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-12 13:53:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Emacs support, own installed dirs (2.38 KB, patch)
2007-04-05 19:04 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2007-04-05 19:04:32 UTC
Here's a patch that adds Emacs support for Mercurial in a subpackage.

Included is also a fix for unowned dirs in the package; --record doesn't take
care of them.

Comment 1 Ville Skyttä 2007-04-05 19:04:32 UTC
Created attachment 151800 [details]
Emacs support, own installed dirs

Comment 2 Till Maas 2007-08-11 21:31:10 UTC
*** Bug 245359 has been marked as a duplicate of this bug. ***

Comment 3 Till Maas 2007-08-11 21:46:13 UTC
I added the co-maintainers to CC, maybe one of them has the time to process this
request.

Comment 4 Bug Zapper 2008-04-03 23:58:06 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 5 Ville Skyttä 2008-04-05 05:28:20 UTC
Reassigning to current maintainer.

Comment 6 Ville Skyttä 2008-04-11 17:46:03 UTC
Ick, I see a xemacs package has been added as well.  The next version of
xemacs-packages-extra will ship mercurial.el too (in the upstream xemacs vc
package).  Having two versions installed is asking for trouble, so one of them
should be dropped.  I'd prefer to keep the version shipping with
xemacs-packages-extra because that's a version that has been tested to work with
XEmacs and integrated well with their package system.  Thoughts?

Also, my fix for the unowned dirs seems to have been dropped without any
comment.  Why is that?  Was there a problem with it?

Comment 7 Neal Becker 2008-04-11 23:19:25 UTC
Do you believe the xemacs version is different?  If so, we should go with that 
one.  Otherwise, I'd prefer the symmetry of having both emacs and xemacs 
together - otherwise user's are going to be a bit confused.

As to the unowned dirs, could you please tell me what are the unowned dirs?  
I've looked at your patch but I don't see which change you made to address 
this issue.

Comment 8 Ville Skyttä 2008-04-12 09:06:30 UTC
The XEmacs version is not different right now.  But it has been and there's no
guarantee it won't be in the future (I know, I more or less maintain it in
XEmacs upstream).  I'd argue that XEmacs users who are told that mercurial
support is part of XEmacs packages are going to be confused if it is not. 
Whereas upstream mercurial does not install any Emacs/XEmacs support by default,
so there shouldn't be too many people specifically expecting it from the
mercurial package.  And if XEmacs users use the built in XEmacs packages UI to
update their packages locally, they'll get the XEmacs version in any case.  And
when they report bugs back to XEmacs upstream, more confusion will ensue.

I'd not worry about the symmetry, there are several examples already where
XEmacs stuff lives in xemacs-packages-* and does not have to be provided by
other Fedora packages.

Finding the unowned dirs should be trivial from just looking at the output of
"rpm -ql mercurial".  At least all created dirs below pythonx.x/site-packages
are unowned.  My patch fixes it by not using --record which only records files,
thus leaving dirs unowned unless you add the dirs manually.

Comment 9 Neal Becker 2008-04-12 13:53:55 UTC
1. Agree with moving mercurial xemacs to xemacs-extras.
Note: Personally, I would not have site (load "mercurial") by default.  Too 
bad it's not an autoload.  I installed a site-start, but left this commented 
out so user can decide.

2. Fixed ownership of dirs.  Because we need the list of files to manipulate 
it (for hgk), I kept record but just added the dirs.


Note You need to log in before you can comment on or make changes to this bug.