Bug 235452 - Window borders randomly disappear when desktop effects / compiz enabled
Window borders randomly disappear when desktop effects / compiz enabled
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
8
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-05 16:53 EDT by Bryan Christ
Modified: 2008-04-01 18:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 18:06:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (22.06 KB, text/plain)
2007-11-27 13:17 EST, Jan Vlug
no flags Details
xorg.conf (866 bytes, application/octet-stream)
2007-11-27 13:17 EST, Jan Vlug
no flags Details

  None (edit)
Description Bryan Christ 2007-04-05 16:53:05 EDT
Description of problem:

Window borders randomly disappear when destkop effects are enabled.  ps shows
that compiz is still running, but the only way to get the window borders back is
to log out of gnome and log back in.  I suspect the problem is compiz, but not
sure.  This only started happening recently, so it must be due to a recent
update via yum.

Video is integrated Intel 915

Version-Release number of selected component (if applicable):

compiz-0.3.6-2.fc6
xorg-x11-drv-i810-1.6.5-10.fc6

How reproducible:  Random

Steps to Reproduce:
1.  Install Fedora Core 6
2.  Install latest updates from "updates" and "extras" yum repos
3.  Enable Desktop Effects
4.  Use system until borders eventually vanish -- this may take hours (even days).
  
Actual results:


Expected results:


Additional info:
Comment 1 Vic Ricker 2007-05-24 20:43:17 EDT
This happens to me too on my laptop using nVidia legacy drivers.  Instead of
re-starting X, you can re-run gtk-window-decorator.
Comment 2 Bryan Christ 2007-05-25 10:31:30 EDT
Thanks for the tip.
Comment 3 drago01 2007-05-30 14:53:46 EDT
I had this problem with 0.3.6 too , after building a custom package from git
this no longer happens (should also not happen with 0.4.0/0.5.0)
Comment 4 Bryan Christ 2007-06-06 15:16:13 EDT
I got this error message on the console when it happened this time:


The program 'gtk-window-decorator' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadLength (poly request too large or internal Xlib length erro'.
  (Details: serial 8709696 error_code 16 request_code 154 minor_code 34)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Comment 5 vfiend 2007-06-06 23:58:35 EDT
Yeah, also happens on F7, rerunning gtk-window-decorator works and for the time
being a quickly created menu shortcut for that is convenient enough, hopefully
we'll get a compiz update to the new upstream version soon enough and this'll be
fixed.
Comment 6 Pedro 2007-06-09 13:20:12 EDT
I confirm this happens also in F7.   I did happen to me in FC6.

I did a fresh install of F7 (not an upgrade), and the problem persists.  
At first, the window decorations did appear in Gnome.  Then I played with
enabling/disabling Desktop Effects on my user.   I don't know what happened, but
on the next login to Gnome, the window decorations did not appear.

So I tried DELETING all files for that user (the whole home directory, including
all Gnome config files).   I re-recreate the user.  Login again, and the window
decorations still do not show up.

So I create a completely NEW user, with a brand new home directory.   I login
with this user, and the window decorations do not show up either.   

Some investigation has revealed the following messages in .xsession-errors

----------------------------
Window manager warning: Failed to load theme "Clearlooks": Failed to find a
valid file for theme Clearlooks
Window manager warning: Failed to load theme "Simple": Failed to find a valid
file for theme Simple
Window manager error: Failed to scan themes directory: Error opening directory
'/usr/share/themes': No such file or directory
----------------------------

So I do rpm -qf /usr/share/themes and it tells me that three packages own that
directory:
  gtk2-engines-2.10.0-3.fc7
  metacity-2.18.0-2.fc7
  gtk+-1.2.10-57.fc7

Yet, the /usr/share/themes does NOT exist!!   (I am finding these facts out, as
I investigate and write this report here).   I assume that the folder must have
existed at some point, when I installed F7 brand new.

So it seems that my problem is that /usr/share/themes has been wiped out, and
now Gnome cannot find the theme for the window decorations...
If I run 'gtk-window-decorator' it cannot run.

I hope this report can help find whether compiz is messing up the
/usr/share/themes for some reason.

This bug is similar to 228644.

I will post anything else if I find a cause of this problem.

Comment 7 Pedro 2007-06-09 14:43:13 EDT
I fixed the problems in my system, although I don't know what the root cause of
the problem was in the beginning.

I removed packages gtk2-engines-2.10.0-3.fc7, metacity-2.18.0-2.fc7 and
gtk+-1.2.10-57.fc7.  Then I installed them with yum.   The /usr/share/themes
folder is back, with all its contents.   I still don't know how it disappeared
in the first place.

Although I didn't mention it in my previous comment, compiz was not working for
me either.  I found out it was due to the fact I had two different 'compiz'
binaries in my system.   To fix the problem, I simply removed the binary I
compiled myself some time ago,  and I kept the compiz rpm.    I can enable
Desktop Effect again, and it works.

However, if I login through GDM when running inside a Xnest, for instance,
compiz cannot run (because composite extentions are not present in the X session
inside Xnest).   That's fine, but then because compiz does not run, the window
decorations do not show up either.   At that point I have to either disable
desktop effects,  or login on the actual X console rather than through Xnest.
Comment 8 Matěj Cepl 2007-11-19 10:28:04 EST
Bryan, could you reproduce this bug even after applying stuff in comment 7, please?
Comment 9 Bryan Christ 2007-11-19 15:43:12 EST
Unfortunately, I no longer have this system.  I have a Fedora 7 (9-27-07 Unity
Respin) system with compiz enable on one of my notebooks and I have not seen
this problem surface.  However, I would be hesitant to call this problem fixed
on account of the report in comment #6.
Comment 10 Jan Vlug 2007-11-19 15:52:24 EST
Sometimes I have similar problems. Although I do not know how to reproduce it. I
upgraded from fc7 to fc8.
Comment 11 Matěj Cepl 2007-11-21 07:25:11 EST
OK, Jan, you get a month to reproduce it with F7 or F8 and attach
/var/log/Xorg.0.log and /etc/X11/xorg.conf as separate uncompressed attachments
to this bug. If you won't make, I will have to close this bug as unrepsoducible.
Thanks.
Comment 12 Jan Vlug 2007-11-27 13:17:14 EST
Created attachment 270001 [details]
Xorg.0.log
Comment 13 Jan Vlug 2007-11-27 13:17:54 EST
Created attachment 270021 [details]
xorg.conf
Comment 14 Bryan Christ 2008-03-13 12:44:15 EDT
I haven't seen this problem for quite a while with the latest stable updates for
F7.  Has anyone else experienced this lately?  If not, I recommend closing this
BZ in a few weeks.
Comment 15 Matěj Cepl 2008-04-01 18:06:09 EDT
So, I will do.

Note You need to log in before you can comment on or make changes to this bug.