Bug 235556 - needinfo borked
needinfo borked
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-07 04:00 EDT by David Lawrence
Modified: 2013-06-23 22:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-22 15:11:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2007-04-07 04:00:44 EDT
Description of problem:
I've been doing triaging on bugs where I am in the CC and matdm has marked them
as needinfo from anyone because they were originally filed against FC5/6 test
versions.

When I add a comment and check the "I am providing the requested info" checkbox,
then the status doesn't change from needinfo back to assigend, but stays need
info. Where one would expect it to change back to assigned.

---

Because of this I have to change the bug from needinfo -> assigned manually,
when i do this (after first trying to get BZ to this auto with the checkbox) I
get the following mail:

Hans de Goede <j.w.r.degoede@hhs.nl> has cancelled Hans de Goede
<j.w.r.degoede@hhs.nl>'s request for needinfo:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=184075

This is not correct as the info was not requested by my but my matdm
Comment 1 David Lawrence 2007-04-11 12:42:48 EDT
Putting into needinfo by anyone to test this. Please make a comment and
try the override checkbox.
Comment 2 Hans de Goede 2007-04-11 13:31:53 EDT
I'm now making a comment and checking the "I am providing the requested
information for this bug." checkbox. However this is different then the original
scenario as there I was only in the CC and here I'm the reporter.
Comment 3 David Lawrence 2007-04-11 14:36:54 EDT
Ok. It may have to do with the person making the comment is not allowed to make
a status change due to not being either the reporter, qa_contact or assigned_to.
I have change the bug to be me as the reporter and added you to the cc list.
Putting into needinfo/reporter. Please try the comment again to see if it changes.
Comment 4 Hans de Goede 2007-04-11 15:17:01 EDT
Trying again, yet another comment with the "I am providing the requested
information for this bug." checkbox checked.
Comment 5 David Lawrence 2007-04-11 15:26:50 EDT
Hmm, that seemed to work as well. What other conditions am I missing?
Comment 6 David Lawrence 2007-04-11 15:33:55 EDT
(In reply to comment #3)
> Ok. It may have to do with the person making the comment is not allowed to make
> a status change due to not being either the reporter, qa_contact or assigned_to.
> I have change the bug to be me as the reporter and added you to the cc list.
> Putting into needinfo/reporter. Please try the comment again to see if it changes.

Just noticed you are a member of fedora_contrib group which has editbugs
privilege for all products so that may explain why this last test case worked.
Comment 7 Hans de Goede 2007-04-11 16:32:25 EDT
Yes, but then the case where I added a comment to the bugs put in needinfo by
matdm should have worked too? Maybe it also has something todo with the person
requesting the needinfo not being the reporter / assignee?
Comment 8 Nils Philippsen 2007-07-18 15:18:35 EDT
Hmm I found the behaviour as described in comment #0 (of this bug) on bug
#147262 where I am the reporter (and my account has privileges galore):

- Ticked "I am providing the information..."
- Found that it's still in NEEDINFO
- Manually changed to ASSIGNED

This may as well have something to do with duplicate "needinfo cancelled" mails
I'm seeing, though that may as well be a) me requesting the NEEDINFO while b)
I'm at the same time assignee of the bug. Shall I open another BZ for this last one?
Comment 9 Nils Philippsen 2007-07-18 15:19:39 EDT
re comment #8, I see that latter behaviour with other bugs, where other people
answer my questions, not the one mentioned.
Comment 10 David Lawrence 2008-09-16 12:55:16 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 11 David Lawrence 2008-09-22 15:11:54 EDT
Should be better in current release. Please reopen if not the case.

Note You need to log in before you can comment on or make changes to this bug.