Bug 235572 - yum choose bad version for some foo-devel (in mock x86_64)
yum choose bad version for some foo-devel (in mock x86_64)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-07 09:22 EDT by Remi Collet
Modified: 2014-01-21 17:57 EST (History)
0 users

See Also:
Fixed In Version: 3.0.5-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 11:16:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fix potential (850 bytes, patch)
2007-04-07 23:51 EDT, Seth Vidal
no flags Details | Diff

  None (edit)
Description Remi Collet 2007-04-07 09:22:50 EDT
Seems to be a regression bug in 3.0.5 (no problem with 3.0.3).

For example, trying to build in mock a package that BR glib2-devel result in :
  Error: Missing Dependency: glib2 = 2.12.3-2.fc6 is needed by package
  glib2-devel

Running with yum debuglvel=9 give more information

When Executing /usr/sbin/mock-helper yum --installroot
  /var/lib/mock/fc6/root resolvedep   'glib2-devel >= 2.0.3' ...

  Searching pkgSack for dep: glib2-devel
  Potential match for glib2-devel from glib2-devel - 2.12.3-2.fc6.i386
  Matched glib2-devel - 2.12.3-2.fc6.i386 to require for glib2-devel
  Potential match for glib2-devel from glib2-devel - 2.12.9-1.fc6.i386
  Matched glib2-devel - 2.12.9-1.fc6.i386 to require for glib2-devel
  0:glib2-devel-2.12.9-1.fc6.i386

That's seems OK

But when  Executing /usr/sbin/mock-helper yum --installroot
  /var/lib/mock/fc6/root install  'glib2-devel >= 2.0.3' ...

  Searching pkgSack for dep: glib2-devel
  Potential match for glib2-devel from glib2-devel - 2.12.3-2.fc6.i386
  Matched glib2-devel - 2.12.3-2.fc6.i386 to require for glib2-devel
  Potential match for glib2-devel from glib2-devel - 2.12.9-1.fc6.i386
  Matched glib2-devel - 2.12.9-1.fc6.i386 to require for glib2-devel
  No other glib2-devel installed, adding to list for potential install
  Solving package glib2-devel - 2.12.3-2.fc6.i386 is installable, not
going through the rest

This occurs when building from FC6 x86_64.

Full (very big) log : http://remi.collet.free.fr/files/root.log

Thanks for help.
Comment 1 Seth Vidal 2007-04-07 11:56:19 EDT
rpm -q yum

I need to know the specific version-release of 3.0.5 from fc6 on this, please.
Comment 2 Remi Collet 2007-04-07 12:53:09 EDT
The one from "updates" repository : yum-3.0.5-1.fc6

Do you want me to test yum-3.0.5-2.fc6 from testing ?
Comment 3 Remi Collet 2007-04-07 13:03:04 EDT
Same issue with yum-3.0.5-2 from "updates-testing"

Full log (debuglevel=9) : http://remi.collet.free.fr/files/root2.log

Comment 4 Seth Vidal 2007-04-07 23:51:03 EDT
Created attachment 151925 [details]
fix potential
Comment 5 Seth Vidal 2007-04-07 23:52:00 EDT
please test the attached patch. I think it fixes the problem and hopefully
doesn't create more ;)
Comment 6 Jonathan Steffan 2007-04-08 00:14:28 EDT
Fixes the issue(s) I have been having related to this bug.
Comment 7 Remi Collet 2007-04-08 04:09:26 EDT
No more problem with yum-3.0.5-2 + yum-install-by-dep-fix.patch.

Good fixe.
Thanks.
Comment 8 Jeremy Katz 2007-04-09 11:16:53 EDT
3.0.5-2 should be going out as a final update now today.

Note You need to log in before you can comment on or make changes to this bug.