Bug 235613 - initng hangs on system/selinux/dev, system/initial failed.
initng hangs on system/selinux/dev, system/initial failed.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initng (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Malmgren
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-07 20:48 EDT by Sean Stangl
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-09 09:20:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Stangl 2007-04-07 20:48:20 EDT
Description of problem:
 Booting with initng drops to the root shell (su_login), after displaying the
errors found below.

Version-Release number of selected component (if applicable):
 initng-0.6.9-3.fc6

Initng displays the following: ("..." skips irrelevant output)

system/initial/virtcheck start:
	bash_helper[system/initial/virtcheck]: line 5: /var/initng_isvirt: Read-only
file system

...

system/initial/mountvirtfs start:
	mount: proc already mounted
	mount: sys already mounted or /sys busy

12% system/udev/filldev		[done]		( done in 5286ms )

** "/builddir/build/BUILD/initng-0.6.9/plugins/service/initng_service.c",
timeout_SERVICE_START_RUN() line:559:
	20:21:31 -- WARN:	Timeout for start rpocess, service system/selinux/dev.
Killing this process now.
	system/selinux/dev	[SERVICE_START_FAILED_TIMEOUT]

** "/builddir/build/BUILD/initng-0.6.9/plugins/critical/initng_critical.c",
check_critical() line :65:
	20:21:31 -- FAIL:	Service system/initial failed, this is critical, going su_login!!

This is a sulogin offer,
you will be able to login for 2 times (now 00),
...
Give root password for maintenance (or type Control-D to continue)

Service system/mountfs/service FAILED
Comment 1 Daniel Malmgren 2007-05-07 04:36:15 EDT
Sorry for the long delay. Have you tried this on 0.6.10?
Comment 2 Daniel Malmgren 2007-05-07 05:13:53 EDT
Sorry once again. Noticed that 0.6.10 was never built for FC-6. This is now
fixed so that you can easily try with 0.6.10...
Comment 3 Sean Stangl 2007-05-08 10:16:28 EDT
Negative on 0.6.10 pushed for FC6.
Comment 4 Sean Stangl 2007-05-08 16:06:19 EDT
(In reply to comment #3)
> Negative on 0.6.10 pushed for FC6.

Err, that is, 0.6.10 has not been pushed for FC6.
Comment 5 Sean Stangl 2007-05-08 16:49:05 EDT
OK, got the update. I'm still experiencing the same error.

initng hangs after 12% system/udev/filldev for eight to ten minutes, then the
exact same error (as in the original post) is reproduced. This has been
replicated on two unrelated computers.
Comment 6 Daniel Malmgren 2007-05-09 02:35:00 EDT
Did you also upgrade initng-ifiles to latest (0.1.2-1)?
Comment 7 Sean Stangl 2007-05-09 08:50:15 EDT
Alright, I refreshed the packages and that fixes the selinux problem. However,
now, after eth0 failed due to lack of available connection, every service
thereafter began to time out, beginning with service/iptables.

I'd file this in another bug but it's just a continuation of the same.
Comment 8 Daniel Malmgren 2007-05-09 09:20:37 EDT
Ok, I'll close this bug...

Note You need to log in before you can comment on or make changes to this bug.