Bug 235657 - leaking GConfClients ?
leaking GConfClients ?
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eel2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-09 06:06 EDT by Matthias Clasen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 09:18:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2007-04-09 06:06:47 EDT
hunting for some small memleaks in nautilus, I noticed that

eel_gconf_monitor_add
eel_gconf_monitor_remove
eel_gconf_preload_cache

are leaking the clients, since they are using gconf_client_get_default
instead of eel_gconf_client_get_global.
Comment 1 Matthias Clasen 2007-04-09 06:49:22 EDT
A patch is in the upstream bug http://bugzilla.gnome.org/show_bug.cgi?id=427808
Comment 2 Alexander Larsson 2007-04-10 09:17:22 EDT
commited to trunk
Comment 3 Alexander Larsson 2007-04-10 09:18:49 EDT
Uhm, wrong bugzilla. Its been commited upstream. However, this will only leak
the refcount on the global default gconf client object, so its not very
important to backport the fix.
Comment 4 Matthias Clasen 2007-04-10 09:23:32 EDT
Are you sure ? It looks to me as if it leaks one GConfClient per
eel_gconf_monitor_add call.
Comment 5 Alexander Larsson 2007-04-10 09:27:35 EDT
The way i read gconf_client_get_default is that it will always return the same
client object each time. If its created its then set on the engine so that the
next time lookup_client will find it.
Comment 6 Matthias Clasen 2007-04-10 09:38:37 EDT
Ah, ok. Then it is indeed not very important.

Note You need to log in before you can comment on or make changes to this bug.