Bug 235667 - Impossible to change default language for documents.
Impossible to change default language for documents.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-09 09:44 EDT by Erik P. Olsen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 10:43:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screen display of language settings. (210.89 KB, image/jpeg)
2007-04-10 04:44 EDT, Erik P. Olsen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 65129 None None None Never

  None (edit)
Description Erik P. Olsen 2007-04-09 09:44:54 EDT
Description of problem: 
If you install OpenOffice with English as user interface language then the
spellchecker is English by default. If you want to change the spellchecker to
for example Danish and still keep English as the user interface language, then
that does not happen. After exit and reenter OpenOffice the spellchecker is back
to English.

It looks like you are not able to have different languages for these two options.

It has been reported to the bug system for OpenOffice.org but they close the bug
as invalid since vanilla generated OpenOffice does not have this bug. They
mention that it probably is due to incorrect compilation/generation by the packager.

Please see http://www.openoffice.org/issues/show_bug.cgi?id=65129


Version-Release number of selected component (if applicable):
The problem is with OpenOffice version 2.0.2.

How reproducible:


Steps to Reproduce:
1. Select Tools->Options->Language Setting->Languages
2. Check that the user interface labguage is set to "English (USA)"
3. Change under "Default languages for documents" "Western" from "English(USA)"
to "Danish" which BTW must have the check mark before "Danish" to show that the
language dictionary is installed.
4. Press OK and exit OpenOffice
5. Launch OpenOffice again and perform item 1. again

You should now see that "Default languages for documents" is back to "English (USA)"
Comment 1 Caolan McNamara 2007-04-09 10:43:16 EDT
Because it defaults to your locale, you can change it for a given document but
the default language for documents will always default to your locale in fedora.
The UI is a little more clear in >= FC-6 than it is in FC-5. But you can change
your default template to set a different default language for all new documents
but keep the UI in the locale language.
Comment 2 Erik P. Olsen 2007-04-09 15:29:03 EDT
I don't accept that default language for documents defaults to the locale for
the following reasons:
1. If so it makes no sense to have a separate option for it.
2. The maintainer of OpenOffice claims you can set it in vanilla OpenOffice. See
the link above to issue 65129.
3. The locale for my system is set to Danish yet the default language for
documents reverts to English.
Comment 3 Caolan McNamara 2007-04-10 04:04:29 EDT
3. really ? can you just open a gnome-terminal and paste in the output of 
echo $LANG
export LANG=da_DK.UTF-8 and launching writer in FC-6 gives danish as the default
language for documents as I'd expect.

I still think taking the default locale as the default language is a good idea,
and in fact upstream OOo does this too, but only on "first start". On subsequent
starts it will stick to the first set locale and need to be changed by the user
to update. I still want to track the locale in most cases.

But there is a good argument that this should happen only up until the user sets
a locale in the UI i.e. have a "Default" entry which means take language from
the locale but allow a manual selection to override this permanently.
Comment 4 Erik P. Olsen 2007-04-10 04:44:45 EDT
Created attachment 152122 [details]
Screen display of language settings.

This attachment shows the export of the $LANG variable and the subsequent
display of default language for documents as it appears when OpenOffice is
launched after change of the variable.

Note You need to log in before you can comment on or make changes to this bug.