Bug 235673 - cmake: executable shlibs
cmake: executable shlibs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cmake (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-09 10:56 EDT by Rex Dieter
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.4.6-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 12:38:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
executable shlibs (607 bytes, patch)
2007-04-09 10:56 EDT, Rex Dieter
no flags Details | Diff

  None (edit)
Description Rex Dieter 2007-04-09 10:56:46 EDT
Per upstream report:
http://www.cmake.org/Bug/bug.php?op=show&bugid=4805
cmake doesn't make shlibs executable by default, per ChangeLog.txt:
--------------
2006-03-03 18:44  king
...
          Default permissions for shared libraries on
          non-Windows/non-OSX platforms no longer has the execute bit set.
--------------

Attached is a patch to revert that behavior (I think, haven't tested it much)
Comment 1 Rex Dieter 2007-04-09 10:56:49 EDT
Created attachment 151991 [details]
executable shlibs
Comment 2 Rex Dieter 2007-04-16 11:01:20 EDT
I'd say go ahead and patch cmake to "just work" (for us), so that the cmake
guideline can be deployed asap without having to mention the shlibs hack.

It looks like cmake upstream will likely do the right thing soon, but I'd rather
not wait for the next cmake release.
Comment 3 Orion Poplawski 2007-04-16 12:38:26 EDT
Applied the fix from http://public.kitware.com/Bug/bug.php?op=show&bugid=4805
and upstream CVS that uses CMAKE_INSTALL_SO_NO_EXE and makes executable shared
libraries the default except on Debian/Ubuntu.
Comment 4 Rex Dieter 2007-04-16 12:47:14 EDT
Thanks.


Please port changes to FC-5/FC-6 branches too, and we're golden.
Comment 5 Kevin Kofler 2007-05-01 08:22:53 EDT
Yuck, this detects the distro from /proc/version. This is going to break the 
day someone wants to build Fedora packages in a mock chroot on a Debian system:
http://packages.debian.org/unstable/devel/mock
(With mock, the kernel and /proc from the host system is used.)

Can the setting be preseeded somehow in the cmake RPM? Or maybe added to the 
command line of the %cmake macro if that works? Or maybe you can get upstream 
to use a saner method to detect the distribution in use, such as the contents 
of /etc/issue or the existence of /etc/debian_version?
Comment 6 Rex Dieter 2007-05-01 08:38:26 EDT
Kevin, please take your issues upstream, maybe even
http://public.kitware.com/Bug/bug.php?op=show&bugid=4805
they should be made aware of your (imo, valid) reservations.

Note You need to log in before you can comment on or make changes to this bug.