Bug 23568 - zsh-3.0.8-5 i386 signal list is empty
Summary: zsh-3.0.8-5 i386 signal list is empty
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: zsh   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-08 10:16 UTC by Wesley Tanaka
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-08 19:17:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wesley Tanaka 2001-01-08 10:16:45 UTC
With zsh 3.0.8-5 from rawhide, I get the following behavior:

~ % cat

zsh: unknown signal  cat
~ % kill %
~ % 
[3]  + unknown signal  cat
~ % kill -l
ZERR




The expected behavior is:

~ % cat

zsh: suspended  cat
~ % kill %
~ % 
[1]  + terminated  cat
~ % kill -l
HUP INT QUIT ILL TRAP ABRT BUS FPE KILL USR1 SEGV USR2 PIPE ALRM TERM
STKFLT CHLD CONT STOP TSTP TTIN TTOU URG XCPU XFSZ VTALRM PROF WINCH IO PWR
SYS RTMIN

Comment 1 Trond Eivind Glomsrxd 2001-01-08 19:17:08 UTC
Confirmed. A workaround would be to use standard kill instead of the builtin.

Comment 2 Trond Eivind Glomsrxd 2001-01-08 20:01:17 UTC
Fixed by just rebuilding - look for 3.0.8-6

Comment 3 Trond Eivind Glomsrxd 2001-01-11 19:19:51 UTC
*** Bug 23803 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.