Bug 235909 - libnl headers have error on i386
libnl headers have error on i386
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libnl (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
http://buildsys.fedoraproject.org/log...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-10 14:51 EDT by Dennis Gilmore
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 11:01:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2007-04-10 14:51:49 EDT
Description of problem:
Trying to build knetworkmanager update for Fedora and build fails as the 
headers are incorrect 
/usr/include/netlink/rtnetlink-kernel.h:498: error: '__u64' does not name a 
type

build was fine on x86_64 so it seems to be some 32bit  issue

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
build fails

Expected results:
build to succeed 

Additional info:
Comment 1 Neil Horman 2007-04-10 16:18:02 EDT
This strikes me as more of a knetworkmanager issue.  knetworkmanager should not
include rtnetlink-kernel.h directly, but rather netlink.h, which includes
linux/types.h -> asm/types.h, where __u64  is definately defined.  It may be
that knetworkmanager is defining  __STRICT_ANSI__ during its build, which would
cause its lack of definition, but I don't think kde utils define that nominally.
 Likewise, if you were using a compiler other than gcc, __GNUC__ wouldn't be
defined, and you wouldn't get __u64 defined.  Either way, figure out which of
those macros is or isn't defined properly, fix that up, and your problem should
go away. 
Comment 2 Neil Horman 2007-08-29 10:52:51 EDT
ping.  Any update?
Comment 3 Dennis Gilmore 2007-08-29 11:01:25 EDT
sorry forgot about this bug.  I fixed it.  i had to pass an additional switch 
to knetworkmanager which fixed it.

Thanks for the reminder.

Note You need to log in before you can comment on or make changes to this bug.