Bug 235968 - Can't run system-config-network after upgrading ES4 to ES5
Can't run system-config-network after upgrading ES4 to ES5
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: krb5 (Show other bugs)
5.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
: 235969 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-11 00:51 EDT by John Kastner
Modified: 2014-06-30 10:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-26 16:51:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Kastner 2007-04-11 00:51:41 EDT
Description of problem:
Upgraded ES4 to ES5.  Network didn't work.  Tried to run
System -> Administration -> Network
but it errored out.


Version-Release number of selected component (if applicable):
system-config-network 1.3.99

How reproducible:
On my system, happened every time.

Steps to Reproduce:
1. Upgrade ES4 to ES5
2. Click on System -> Administration -> Network
3. Got bug trace back
  
Actual results:
Exception Occurred dialog box popped up.

Expected results:
Expected network configuration dialog

Additional info:
From the Exception Occurred dialog box:

Component: system-config-network
Version: 1.3.99
Summary: TBef2d5f7a __init__.py:13:?:ImportError: /usr/lib/libkrb5.so.3: symbol 
krb5int_c_init_keyblock, version k5crypto_3_MIT not defined in file 
libk5crypto.so.3 with link time reference

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 140, in main
    import gnome
  File "/usr/lib/python2.4/site-packages/gtk-2.0/gnome/__init__.py", line 13, 
in ?
    from _gnome import *
ImportError: /usr/lib/libkrb5.so.3: symbol krb5int_c_init_keyblock, version 
k5crypto_3_MIT not defined in file libk5crypto.so.3 with link time reference

Local variables in innermost frame:
__builtins__: {'IndexError': <class exceptions.IndexError at 0xb7f9a8fc>, 
'help': Type help() for interactive help, or help(object) for help about 
object., 'vars': <built-in function vars>, 'SyntaxError': <class 
exceptions.SyntaxError at 0xb7f9a77c>, 'unicode': <type 'unicode'>, 
'UnicodeDecodeError': <class exceptions.UnicodeDecodeError at 0xb7f9acbc>, 
'isinstance': <built-in function isinstance>, 'copyright': Copyright (c) 2001-
2006 Python Software Foundation.
All Rights Reserved.

Copyright (c) 2000 BeOpen.com.
All Rights Reserved.

Copyright (c) 1995-2001 Corporation for National Research Initiatives.
All Rights Reserved.

Copyright (c) 1991-1995 Stichting Mathematisch Centrum, Amsterdam.
All Rights Reserved., 'NameError': <class exceptions.NameError at 0xb7f9a65c>, 
'dict': <type 'dict'>, 'input': <built-in function input>, 'oct': <built-in 
function oct>, 'SystemExit': <class exceptions.SystemExit at 0xb7f9a32c>, 
'StandardError': <class exceptions.StandardError at 0xb7f9a2cc>, 'repr': <built-
in function repr>, 'sorted': <built-in function sorted>, 'False': False, 
'RuntimeWarning': <class exceptions.RuntimeWarning at 0xb7f9afbc>, 'list': 
<type 'list'>, 'iter': <built-in function iter>, 'reload': <built-in function 
reload>, 'Warning': <class exceptions.Warning at 0xb7f9ae3c>, 'round': <built-
in function round>, 'dir': <built-in function dir>, 'cmp': <built-in function 
cmp>, 'set': <type 'set'>, 'reduce': <built-in function reduce>, 'intern': 
<built-in function intern>, 'issubclass': <built-in function issubclass>, 
'Ellipsis': Ellipsis, 'EOFError': <class exceptions.EOFError at 0xb7f9a53c>, 
'locals': <built-in function locals>, 'slice': <type 'slice'>, 
'FloatingPointError': <class exceptions.FloatingPointError at 0xb7f9aaac>, 
'sum': <built-in function sum>, 'OverflowWarning': <class 
exceptions.OverflowWarning at 0xb7f9af8c>, 'getattr': <built-in function 
getattr>, 'abs': <built-in function abs>, 'exit': 'Use Ctrl-D (i.e. EOF) to 
exit.', 'True': True, 'FutureWarning': <class exceptions.FutureWarning at 
0xb7faf02c>, 'None': None, 'hash': <built-in function hash>, 'len': <built-in 
function len>, 'credits':     Thanks to CWI, CNRI, BeOpen.com, Zope Corporation 
and a cast of thousands
    for supporting Python development.  See www.python.org for more 
information., 'frozenset': <type 'frozenset'>, '__name__': '__builtin__', 
'ord': <built-in function ord>, 'super': <type 'super'>, '_': <bound method 
i18n.gettext of <rhpl.translate.i18n instance at 0xb7ce32ec>>, 'TypeError': 
<class exceptions.TypeError at 0xb7f9a2fc>, 'license': Type license() to see 
the full license text, 'KeyboardInterrupt': <class exceptions.KeyboardInterrupt 
at 0xb7f9a38c>, 'UserWarning': <class exceptions.UserWarning at 0xb7f9ae6c>, 
'filter': <built-in function filter>, 'range': <built-in function range>, 
'staticmethod': <type 'staticmethod'>, 'SystemError': <class 
exceptions.SystemError at 0xb7f9addc>, 'pow': <built-in function pow>, 
'RuntimeError': <class exceptions.RuntimeError at 0xb7f9a56c>, 'float': <type 
'float'>, 'StopIteration': <class exceptions.StopIteration at 0xb7f9a29c>, 
'globals': <built-in function globals>, 'divmod': <built-in function divmod>, 
'enumerate': <type 'enumerate'>, 'apply': <built-in function apply>, 
'LookupError': <class exceptions.LookupError at 0xb7f9a8cc>, 'open': <type 
'file'>, 'quit': 'Use Ctrl-D (i.e. EOF) to exit.', 'basestring': <type 
'basestring'>, 'UnicodeError': <class exceptions.UnicodeError at 0xb7f9ab6c>, 
'zip': <built-in function zip>, 'hex': <built-in function hex>, 'long': <type 
'long'>, 'ReferenceError': <class exceptions.ReferenceError at 0xb7f9adac>, 
'ImportError': <class exceptions.ImportError at 0xb7f9a3ec>, 'chr': <built-in 
function chr>, 'xrange': <type 'xrange'>, 'type': <type 'type'>, '__doc__': 
"Built-in functions, exceptions, and other objects.\n\nNoteworthy: None is the 
`nil' object; Ellipsis represents `...' in slices.", 'Exception': <class 
exceptions.Exception at 0xb7f9a26c>, 'tuple': <type 'tuple'>, 
'UnicodeTranslateError': <class exceptions.UnicodeTranslateError at 
0xb7f9ad4c>, 'reversed': <type 'reversed'>, 'UnicodeEncodeError': <class 
exceptions.UnicodeEncodeError at 0xb7f9abfc>, 'IOError': <class 
exceptions.IOError at 0xb7f9a47c>, 'hasattr': <built-in function hasattr>, 
'delattr': <built-in function delattr>, 'setattr': <built-in function setattr>, 
'raw_input': <built-in function raw_input>, 'SyntaxWarning': <class 
exceptions.SyntaxWarning at 0xb7f9af5c>, 'compile': <built-in function 
compile>, 'ArithmeticError': <class exceptions.ArithmeticError at 0xb7f9a98c>, 
'str': <type 'str'>, 'property': <type 'property'>, 'MemoryError': <class 
exceptions.MemoryError at 0xb7f9ae0c>, 'int': <type 'int'>, '__import__': 
<built-in function __import__>, 'KeyError': <class exceptions.KeyError at 
0xb7f9a95c>, 'coerce': <built-in function coerce>, 'PendingDeprecationWarning': 
<class exceptions.PendingDeprecationWarning at 0xb7f9af2c>, 'file': <type 
'file'>, 'EnvironmentError': <class exceptions.EnvironmentError at 0xb7f9a41c>, 
'unichr': <built-in function unichr>, 'id': <built-in function id>, 'OSError': 
<class exceptions.OSError at 0xb7f9a4dc>, 'DeprecationWarning': <class 
exceptions.DeprecationWarning at 0xb7f9aecc>, 'min': <built-in function min>, 
'execfile': <built-in function execfile>, 'complex': <type 'complex'>, 'bool': 
<type 'bool'>, 'ValueError': <class exceptions.ValueError at 0xb7f9ab0c>, 
'NotImplemented': NotImplemented, 'map': <built-in function map>, 'buffer': 
<type 'buffer'>, 'max': <built-in function max>, 'object': <type 'object'>, 
'TabError': <class exceptions.TabError at 0xb7f9a83c>, 'callable': <built-in 
function callable>, 'ZeroDivisionError': <class exceptions.ZeroDivisionError at 
0xb7f9aa1c>, 'eval': <built-in function eval>, '__debug__': True, 
'IndentationError': <class exceptions.IndentationError at 0xb7f9a80c>, 
'AssertionError': <class exceptions.AssertionError at 0xb7f9a89c>, 
'classmethod': <type 'classmethod'>, 'UnboundLocalError': <class 
exceptions.UnboundLocalError at 0xb7f9a6bc>, 'NotImplementedError': <class 
exceptions.NotImplementedError at 0xb7f9a5cc>, 'AttributeError': <class 
exceptions.AttributeError at 0xb7f9a74c>, 'OverflowError': <class 
exceptions.OverflowError at 0xb7f9a9bc>}
__file__: None
__path__: None
__name__: None
__doc__: None
Comment 3 Phil Knirsch 2008-04-28 06:27:34 EDT
*** Bug 235969 has been marked as a duplicate of this bug. ***
Comment 4 RHEL Product and Program Management 2008-06-02 16:38:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Phil Knirsch 2008-06-13 08:41:22 EDT
This bug needs a review from the component owner before granting Devel ACK.

Thanks,

Read ya, Phil
Comment 6 Harald Hoyer 2008-06-19 11:16:12 EDT
not a bug of s-c-network

/usr/lib/libkrb5.so.3: symbol 
krb5int_c_init_keyblock, version k5crypto_3_MIT not defined in file 
libk5crypto.so.3 with link time reference

# # rpm -qf /usr/lib/libkrb5.so.3
krb5-libs

Comment 7 Nalin Dahyabhai 2008-06-27 11:37:31 EDT
This is rather strange -- the libraries in RHEL 5 provide what's listed as
missing here (at least according to objdump -xT).

John, can you run 'rpm -qa --qf "%{name}-%{version}-%{release}.%{arch}" "krb5*"'
and paste the results here?  I'm suspecting something went wrong during the
upgrade and your system was left with a mixture of libraries from different
releases.
Comment 8 RHEL Product and Program Management 2008-10-27 14:23:14 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 11 RHEL Product and Program Management 2010-03-26 16:51:27 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 12 John Kastner 2014-06-30 10:23:25 EDT
Reasonable to close this bug report after so very long.  I'd forgotten about it years later until Bugzilla poked me again.  After all it's been years.

Here is some of the requested information:

>rpm -qa --qf "%{name}-%{version}-%{release}.%{arch}" "krb5*"
krb5-libs-1.6.1-71.el5_10.1.i386krb5-auth-dialog-0.7-1.i386krb5-workstation-1.6.1-71.el5_10.1.i386

When originally reported I tried the upgrade several times with the same result but have since resolved this for my needs.  Perhaps it is relevant that I'm using VMware Version 6.0.3 on a MacBook Pro running Mac OS X 10.9.3 (Mavericks).  The resolution involved just installing RHEL5 directly instead of upgrading from RHEL4.

Note You need to log in before you can comment on or make changes to this bug.