Bug 236053 - Add Advanced Platform & Client VT Channels to Evals
Add Advanced Platform & Client VT Channels to Evals
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Brandon Perkins
:
Depends On: 82114
Blocks: 233172
  Show dependency treegraph
 
Reported: 2007-04-11 14:06 EDT by Matt Webbink
Modified: 2007-04-23 22:23 EDT (History)
2 users (show)

See Also:
Fixed In Version: rhn500
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-23 22:23:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sku-mappings_041107.csv (34.89 KB, text/csv)
2007-04-11 14:06 EDT, Matt Webbink
no flags Details
sku-mappings_041307.csv (57.61 KB, text/csv)
2007-04-13 17:53 EDT, Matt Webbink
no flags Details
list of sub-sku's that provide rhel-cluster, but not rhel-server-cluster (production) (524 bytes, text/plain)
2007-04-16 10:39 EDT, Bret McMillan
no flags Details
list of sub-sku's that provide rhel-cluster, but not rhel-server-cluster (webqa) (326 bytes, text/plain)
2007-04-16 10:44 EDT, Bret McMillan
no flags Details
sku-mappings_041707.csv (86.11 KB, text/csv)
2007-04-17 15:07 EDT, Matt Webbink
no flags Details

  None (edit)
Description Matt Webbink 2007-04-11 14:06:30 EDT
The attached channel mappings (sku-mappings_041107.csv) add the following
channels to the many eval offerings:

client-vt
server-cluster
server-cluster-storage
virtualization_host_platform

Adding these channels will enable Advanced Platform, as well as Multi-OS
functionality within these evals.

This will require a re-poll.
Comment 1 Matt Webbink 2007-04-11 14:06:31 EDT
Created attachment 152305 [details]
sku-mappings_041107.csv
Comment 2 Matt Webbink 2007-04-13 17:53:18 EDT
Created attachment 152594 [details]
sku-mappings_041307.csv
Comment 3 Matt Webbink 2007-04-13 17:54:42 EDT
The attached channel mappings (sku-mappings_041307.csv) correct the issues
documented here:

http://wiki.rhndev.redhat.com/wiki/RHN_Hosted_Watch_List#GFS_mappings

Please note:  SER0216US, SVC0372, SVC0373, SVC0374, SVC0375, WAR0372, WAR0377
are correct as is (i.e., RHEL AP should not include access to rhel-cluster and
rhel-gfs; while SER0216US is a Cluster Suite only eval).
Comment 4 Bret McMillan 2007-04-14 21:23:27 EDT
These are now on webqa.
Comment 5 Bret McMillan 2007-04-16 10:39:33 EDT
Created attachment 152690 [details]
list of sub-sku's that provide rhel-cluster, but not rhel-server-cluster (production)

Matt & Robb,

At Robb's suggestion, I re-ran the query focused cluster suite to cluster
mappings, and found a number of skus in production that don't seem mapped
correctly either.  I ran the query also on webqa to see if the changes in this
bug fixed them; they did not.  I'll upload the webqa-specific list in a moment.
Comment 6 Bret McMillan 2007-04-16 10:45:00 EDT
Created attachment 152696 [details]
list of sub-sku's that provide rhel-cluster, but not rhel-server-cluster (webqa)

Now attaching the webqa-specific sku list...
Comment 7 Matt Webbink 2007-04-16 10:47:32 EDT
RHEL AS 2.1 included Cluster Suite.  I need Product Marketing to confirm these
customers should have access to the RHEL 5 Cluster Suite channel (I assume they
should).

I fear this will significantly increase the re-poll.
Comment 8 Rob Kenna 2007-04-16 11:45:33 EDT
Yes, they should have access to the Cluster subchannel in RHEL 5.  This is true
anyway, as an AS customer should be converted to an AP customer which then
receives both ClusterStorage and Cluster sub channels.
Comment 9 Rob Kenna 2007-04-16 11:58:21 EDT
re: Comment #3:

Matt is correct in saying:
"... RHEL AP should not include access to rhel-cluster and rhel-gfs.."
Comment 10 Matt Webbink 2007-04-17 15:07:32 EDT
Created attachment 152845 [details]
sku-mappings_041707.csv

The attached .csv mappings file addresses all SKUs determined to require the
RHEL 5 cluster and/or cluster storage channels.

A handful of these SKUs represent RHEL AS subscriptions from the v.2.1
timeframe.  I'm not sure how prevalent these are, but these could impact the
duration of the required re-poll.
Comment 11 Bret McMillan 2007-04-19 19:16:32 EDT
Applied to webqa.  Be advised webqa will likely have a refresh on Friday or
Monday (should be announced on rhn-ccb-list), we'll have to re-run these when it
happens.

Matt:  in the future, please do 2 things:
1)  name the csv with the following convention:  xxxxx.csv, where xxxx is the
bug number
2)  make sure there are no "None"'s in the csv file; causes the csv code to barf
on those values (seems to be happening w/ config_admin user role rows)

This will most likely affect between 7k to 8k orgs; probably should run at night
in production, but I don't think we need to wait until any weekend.
Comment 12 Matt Webbink 2007-04-20 11:00:47 EDT
This looks good from my perspective.

This should also resolve the issue noted in bug # 233172.

Please push to production.
Comment 13 Bret McMillan 2007-04-20 14:54:55 EDT
Matt, please review:

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=233172#c15

I think that needs addressed on webqa before we can push this out.
Comment 14 Matt Webbink 2007-04-20 15:08:07 EDT
This is addressed with the mappings provided in sku-mappings_041707.csv.
Comment 15 Bret McMillan 2007-04-23 22:23:23 EDT
Changes have been run in production:

Processing item WAR0378
Processing item WAR0031US
Processing item WAR0064US
Processing item WAR0278
Processing item SER0189US
Processing item SER0133US
Processing item WAR0277
Processing item SER0135US
Processing item WAR0092
Processing item WAR0090
Processing item WAR0091
Processing item SVC0042RW
Processing item RHN019RW
Processing item SER0206US
Processing item RHN037
Processing item RHN039
Processing item WARRHNAS5
Processing item SVC0042
Processing item RHN019
Processing item SER0252US
Processing item SER0218US
Processing item SVC0001
Processing item SER0198US
Processing item SVC0003
Processing item SVC0002
Processing item RHNSAT31FREE
Processing item RHNSATFREE
Processing item WAR0089
Processing item RHN020RW
Processing item WAR0207
Processing item WAR0065US
Processing item SER0251US
Processing item SYS0042
Processing item SER0207US
Processing item SER0202US
Processing item WAR0081
Processing item SER0196US
Processing item SER0212US
Processing item SER0194US
Processing item WAR0086
Processing item SER0216US
Processing item WAR0088
Processing item WAR0200
Processing item SER0245US
Processing item SER0232US
Processing item SVC0070
Processing item SVC0014
Processing item SVC0073
Processing item RHN020
Processing item SVC0013
Processing item WAR0288
Processing item SVC0070RW
Processing item WAR0293
Processing item SVC0183
Processing item RHN040
Processing item SER0235US
Processing item SER0197US
Processing item SVC0377
Processing item SER0228US
Processing item SVC0145
Processing item SER0195US
Processing item SER0134US
Processing item SER0209US
Processing item WARRHNAS
Processing item SVC0379
Processing item SVC0378
  
Commit specified. Scheduling product repolls...
  0 orgs have active WAR0378 lines
  0 orgs have active WAR0031US lines
  1 orgs have active WAR0064US lines
  4 orgs have active WAR0278 lines
  0 orgs have active SER0189US lines
  8 orgs have active SER0133US lines
  11 orgs have active WAR0277 lines
  0 orgs have active SER0135US lines
  364 orgs have active WAR0092 lines
  163 orgs have active WAR0090 lines
  33 orgs have active WAR0091 lines
  74 orgs have active SVC0042RW lines
  17 orgs have active RHN019RW lines
  8 orgs have active SER0206US lines
  1 orgs have active RHN037 lines
  112 orgs have active RHN039 lines
  3 orgs have active WARRHNAS5 lines
  837 orgs have active SVC0042 lines
  283 orgs have active RHN019 lines
  0 orgs have active SER0252US lines
  0 orgs have active SER0218US lines
  13 orgs have active SVC0001 lines
  0 orgs have active SER0198US lines
  7 orgs have active SVC0003 lines
  17 orgs have active SVC0002 lines
  1 orgs have active RHNSAT31FREE lines
  248 orgs have active RHNSATFREE lines
  6 orgs have active WAR0089 lines
  14 orgs have active RHN020RW lines
  100 orgs have active WAR0207 lines
  1 orgs have active WAR0065US lines
  0 orgs have active SER0251US lines
  0 orgs have active SYS0042 lines
  8 orgs have active SER0207US lines
  8 orgs have active SER0202US lines
  796 orgs have active WAR0081 lines
  0 orgs have active SER0196US lines
  0 orgs have active SER0212US lines
  0 orgs have active SER0194US lines
  595 orgs have active WAR0086 lines
  0 orgs have active SER0216US lines
  111 orgs have active WAR0088 lines
  1472 orgs have active WAR0200 lines
  0 orgs have active SER0245US lines
  2 orgs have active SER0232US lines
  966 orgs have active SVC0070 lines
  0 orgs have active SVC0014 lines
  68 orgs have active SVC0073 lines
  404 orgs have active RHN020 lines
  4 orgs have active SVC0013 lines
  50 orgs have active WAR0288 lines
  0 orgs have active SVC0070RW lines
  258 orgs have active WAR0293 lines
  50 orgs have active SVC0183 lines
  172 orgs have active RHN040 lines
  0 orgs have active SER0235US lines
  0 orgs have active SER0197US lines
  11 orgs have active SVC0377 lines
  0 orgs have active SER0228US lines
  4 orgs have active SVC0145 lines
  0 orgs have active SER0195US lines
  12 orgs have active SER0134US lines
  0 orgs have active SER0209US lines
  281 orgs have active WARRHNAS lines
  1 orgs have active SVC0379 lines
  3 orgs have active SVC0378 lines
  Queue now contains 6495 orgs
Success. Committing transaction.

Note You need to log in before you can comment on or make changes to this bug.