Bug 236067 - Update requested for lcms ( 0.17 is out )
Update requested for lcms ( 0.17 is out )
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lcms (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-11 15:25 EDT by Nicolas Chauvet (kwizart)
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 19:07:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2007-04-11 15:25:35 EDT
Cinepaint 0.22 requires lcms >= 0.16
This package is currently in review but i plan to build it for fc6 and devel
lcms in fc6 is 0.15

thx
Comment 1 Andreas Bierfert 2007-04-25 16:33:40 EDT
Hm I wonder why this one got assigned to me.. for FC6 this is part of Core.
Reassigning
Comment 2 Alexander Larsson 2007-05-02 04:52:43 EDT
0.16 seems to have new API and stuff. Seems a bit risky to upgrade.
Do anyone know of the general quality in backwards compat and
avoid-breaking-old-apps of the lcms releases? 
Comment 3 Nicolas Chauvet (kwizart) 2007-05-02 11:12:45 EDT
[root@Kwizatz ~]# repoquery --whatrequires --alldeps lcms 
kdegraphics-7:3.5.4-1.fc6.x86_64
ImageMagick-0:6.2.8.0-4.fc6.i386
enblend-0:3.0-4.fc6.x86_64
ImageMagick-0:6.2.8.0-3.fc6.1.i386
ImageMagick-perl-0:6.2.8.0-3.fc6.1.x86_64
libmng-0:1.0.9-5.1.x86_64
ImageMagick-0:6.2.8.0-3.fc6.1.x86_64
ImageMagick-0:6.2.8.0-3.fc6.x86_64
nip2-0:7.10.21-1.fc6.x86_64
vips-tools-0:7.10.21-1.fc6.x86_64
lcms-devel-0:1.15-1.2.2.x86_64
lcms-devel-0:1.15-1.2.2.i386
gimp-2:2.2.13-1.fc6.x86_64
ImageMagick-perl-0:6.2.8.0-4.fc6.x86_64
digikam-0:0.9.1-1.fc6.x86_64
k3d-0:0.6.5.0-1.fc6.x86_64
python-lcms-0:1.15-1.2.2.x86_64
ufraw-0:0.9.1-1.fc6.x86_64
ImageMagick-perl-0:6.2.8.0-3.fc6.x86_64
ufraw-gimp-0:0.11-3.fc6.x86_64
ufraw-0:0.11-3.fc6.x86_64
ImageMagick-0:6.2.8.0-4.fc6.x86_64
lcms-0:1.15-1.2.2.i386
scribus-0:1.3.3.6-1.fc6.x86_64
inkscape-0:0.45.1-1.fc6.x86_64
DevIL-0:1.6.8-0.11.rc2.fc6.x86_64
lcms-0:1.15-1.2.2.x86_64
inkscape-0:0.45-1.fc6.x86_64
gnome-commander-0:1.2.3-5.fc6.x86_64
wine-cms-0:0.9.32-1.fc6.i386
vips-0:7.10.21-1.fc6.x86_64
foo2zjs-0:0.20060929-1.lvn6.x86_64
wine-cms-0:0.9.35-1.fc6.i386
GraphicsMagick-0:1.1.7-7.fc6.x86_64
libmng-0:1.0.9-5.1.i386
foo2hp-0:0.20060929-1.lvn6.x86_64
koffice-krita-0:1.6.2-3.fc6.1.x86_64
wine-cms-0:0.9.36-1.fc6.i386
kdegraphics-7:3.5.6-0.1.fc6.i386
ImageMagick-0:6.2.8.0-3.fc6.i386
f-spot-0:0.2.1-1.fc6.x86_64
kdegraphics-7:3.5.6-0.1.fc6.x86_64
GraphicsMagick-perl-0:1.1.7-7.fc6.x86_64
LabPlot-0:1.5.1.5-6.fc6.x86_64
rawstudio-0:0.5.1-1.fc6.x86_64
digikam-0:0.9.1-1.fc6.1.x86_64
dcraw-0:0.0.20060521-1.1.x86_64

rebuild lcms from devel for FC-6 x86_64
upgrading (everthing went fine)
quick testing usability of gimp scribus inkscape : fine at this step


[root@Kwizatz ~]# ldd $(which gimp) |grep cms
[root@Kwizatz ~]# ldd $(which inkscape) |grep cms
        liblcms.so.1 => /usr/lib64/liblcms.so.1 (0x00002aaaaacf7000)
[root@Kwizatz ~]# ldd $(which scribus) |grep cms
        liblcms.so.1 => /usr/lib64/liblcms.so.1 (0x00002aaaaaae2000)
[root@Kwizatz ~]# ldd $(which enblend) |grep cms
        liblcms.so.1 => /usr/lib64/liblcms.so.1 (0x00002aaaaaec4000)

SONAME didn't changed, so i consider API enhancement rather than API changes...

If there is a need to check futher, maybe we can build some app that BR it to
see if ever there is build warning...

Upgrading seems safe to me !...
Comment 4 Nicolas Chauvet (kwizart) 2007-05-12 17:42:09 EDT
Now cinepaint is closed to be acceptable
This is a blocking bug...

What is the current thought about this bug?

On my system, updating and using lcms 1.16 (rebuild from devel) work fine at
runtime with most of these apps...

Please update it - There is a need to have cinepaint on Fedora 6 also!




Comment 5 Alexander Larsson 2007-05-14 05:10:04 EDT
My thought is that i don't have time to do this, but i'm working on getting a
new maintainer.
Comment 6 Nicolas Chauvet (kwizart) 2007-08-16 18:00:16 EDT
lcms 0.17 is out!

We were short in updating it to 0.16 last time, so i'm taking it early...
I hope that we could get it for Fedora Core 8... It is still the time...
(for now)
Comment 7 Nicolas Chauvet (kwizart) 2007-09-10 19:07:54 EDT
This bug should be closed now...

lcms in EL-5 is still in 1.15. Now I have with 1.17 without problem well on FC6
(which initially have lcms 1.15 also). Actually only the current cinepaint
version Requires: lcms >= 0.16 so that's prevent me to build for EL-5, and lcms
1.17 introduced some changes... 

So I don't know how we can update it for EL-5 probably an update to 0.16 is
better for now...

Did you solved your commit problem ?

Note You need to log in before you can comment on or make changes to this bug.