Bug 236406 - misrendering of apostrophes... sometimes
misrendering of apostrophes... sometimes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-13 12:56 EDT by Zack Cerza
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 11:36:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (64.98 KB, image/png)
2007-04-13 12:56 EDT, Zack Cerza
no flags Details
message source (4.53 KB, text/plain)
2007-04-13 13:41 EDT, Zack Cerza
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 377098 None None None Never

  None (edit)
Description Zack Cerza 2007-04-13 12:56:37 EDT
Description of problem:
eh, just check out the screenshot :)

Version-Release number of selected component (if applicable):
thunderbird-2.0.0.0-0.4.rc1.fc7.i386
Comment 1 Zack Cerza 2007-04-13 12:56:37 EDT
Created attachment 152556 [details]
screenshot
Comment 2 Christopher Aillon 2007-04-13 13:21:38 EDT
Are those actual apostrophes and not the curly special character that you might
not have a glyph installed for?
Comment 3 Zack Cerza 2007-04-13 13:29:41 EDT
Well, that's why I posted the 'view source' window for that message. It seems to
do fine. If I don't have the glyph, do you have an idea of what I might be missing?
Comment 4 Zack Cerza 2007-04-13 13:41:45 EDT
Created attachment 152564 [details]
message source
Comment 5 Christopher Aillon 2007-04-13 14:11:33 EDT
Might be https://bugzilla.mozilla.org/show_bug.cgi?id=377098
Comment 6 Matěj Cepl 2007-04-16 09:25:29 EDT
Or might be poorly set encoding of the given message -- it looks like TB trying
to display as ASCII something which is actually CP1251. Reporter, could you
please check in TB, that it recognizes correctly encoding of the message
(View/Encoding menu)?

Notice also that curly quotes/apostrophes are NOT part of ISO-8859-1 -- quite
often what is marked as ISO-8859-1 is actually Microsoft's CP1251, which is adds
support for couple of characters (including curly quotes, apostrophes, etc.) in
very broken manner. If it is the case, blame author of the message, not
Thunderbird which did, what it was supposed to.

If the message is not private (and it doesn't seem to be) could you please
attach it to this bug as an attachment as well, please?
Comment 7 Zack Cerza 2007-04-16 11:27:22 EDT
Matej,

You're right, the real encoding is CP1251. I guess Thunderbird isn't at fault here.

The message is already attached.
Comment 8 Matěj Cepl 2007-04-16 11:36:53 EDT
OK, then it is NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.