Bug 236440 - fc4 kernel update broken
fc4 kernel update broken
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-13 19:22 EDT by gin
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-13 19:34:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gin 2007-04-13 19:22:10 EDT
Can not update fedora core 4 installation with
`core/updates/4/x86_64/kernel-2.6.17-1.2142_FC4.x86_64.rpm'.

rpm -Uv
core/updates/4/x86_64/{kernel-2.6.17-1.2142_FC4.x86_64.rpm,kernel-devel-2.6.17-1.2142_FC4.x86_64.rpm,kernel-doc-2.6.17-1.2142_FC4.noarch.rpm}
error: Failed dependencies:
	kernel = 2.6.11-1.1369_FC4 is needed by (installed)
cman-kernel-2.6.11.5-20050601.152643.FC4.2.x86_64
	kernel = 2.6.11-1.1369_FC4 is needed by (installed)
dlm-kernel-2.6.11.5-20050601.152643.FC4.2.x86_64
	kernel = 2.6.11-1.1369_FC4 is needed by (installed)
GFS-kernel-2.6.11.8-20050601.152643.FC4.2.x86_64
	kernel = 2.6.11-1.1369_FC4 is needed by (installed)
gnbd-kernel-2.6.11.2-20050420.133124.FC4.35.x86_64
	/lib/modules/2.6.11-1.1369_FC4 is needed by (installed)
cman-kernel-2.6.11.5-20050601.152643.FC4.2.x86_64
	/lib/modules/2.6.11-1.1369_FC4 is needed by (installed)
dlm-kernel-2.6.11.5-20050601.152643.FC4.2.x86_64
	/lib/modules/2.6.11-1.1369_FC4 is needed by (installed)
GFS-kernel-2.6.11.8-20050601.152643.FC4.2.x86_64
	/lib/modules/2.6.11-1.1369_FC4 is needed by (installed)
gnbd-kernel-2.6.11.2-20050420.133124.FC4.35.x86_64

There is no replacement for these outdated packages.  Their updates
are useless.

rpm -Uv
{kernel-2.6.17-1.2142_FC4.x86_64.rpm,kernel-devel-2.6.17-1.2142_FC4.x86_64.rpm,kernel-doc-2.6.17-1.2142_FC4.noarch.rpm,cman-kernel-2.6.11.5-20050601.152643.FC4.23.x86_64.rpm,cman-kernheaders-2.6.11.5-20050601.152643.FC4.23.x86_64.rpm,dlm-kernel-2.6.11.5-20050601.152643.FC4.22.x86_64.rpm,dlm-kernheaders-2.6.11.5-20050601.152643.FC4.22.x86_64.rpm,GFS-kernel-2.6.11.8-20050601.152643.FC4.25.x86_64.rpm,GFS-kernheaders-2.6.11.8-20050601.152643.FC4.25.x86_64.rpm,gnbd-kernel-2.6.11.2-20050420.133124.FC4.58.x86_64.rpm}
error: Failed dependencies:
	/lib/modules/2.6.15-1.1833_FC4 is needed by
cman-kernel-2.6.11.5-20050601.152643.FC4.23.x86_64
	kernel = 2.6.15-1.1833_FC4 is needed by
cman-kernel-2.6.11.5-20050601.152643.FC4.23.x86_64
	/lib/modules/2.6.15-1.1833_FC4 is needed by
dlm-kernel-2.6.11.5-20050601.152643.FC4.22.x86_64
	kernel = 2.6.15-1.1833_FC4 is needed by
dlm-kernel-2.6.11.5-20050601.152643.FC4.22.x86_64
	/lib/modules/2.6.15-1.1833_FC4 is needed by
GFS-kernel-2.6.11.8-20050601.152643.FC4.25.x86_64
	kernel = 2.6.15-1.1833_FC4 is needed by
GFS-kernel-2.6.11.8-20050601.152643.FC4.25.x86_64
	/lib/modules/2.6.15-1.1833_FC4 is needed by
gnbd-kernel-2.6.11.2-20050420.133124.FC4.58.x86_64
	kernel = 2.6.15-1.1833_FC4 is needed by
gnbd-kernel-2.6.11.2-20050420.133124.FC4.58.x86_64

That is, updates of related packages require nonexistent kernel
package version.
Comment 1 Dave Jones 2007-04-13 19:34:58 EDT
just remove the packages its complaining about if you aren't using them.
(chances are that you aren't).

FC4 is no longer maintained (and hasn't been for some time now), and will
recieve no further updates.

Note You need to log in before you can comment on or make changes to this bug.