Bug 23645 - xinetd closes connections after USR2
xinetd closes connections after USR2
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-09 00:02 EST by Adrian Chung
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-09 14:55:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Chung 2001-01-09 00:02:15 EST
On doing a 'killall -USR2 xinetd' (hard reconfiguration), xinetd should
recheck /etc/hosts.{allow,deny} and make sure that all active servers meet
the current rules.

I have the following problem:

/etc/hosts.allow:

in.telnetd : 192.168.16.0/255.255.255.0

/etc/xinetd.conf:

defaults
{
        instances               = 60
        log_type                = SYSLOG authpriv
        log_on_success          = HOST PID
        log_on_failure          = HOST RECORD
}

service telnet
{
    socket_type			= stream
    wait                        = no
    user                        = root
    server                      = /usr/sbin/in.telnetd
}

When I do a 'killall -USR2 xinetd' via a telnet session from IP
192.168.16.90, the client gets a connection closed, and /var/log/messages
shows:

Jan  8 02:15:56 e-smith xinetd[2578]: Starting hard reconfiguration
Jan  8 02:15:56 e-smith xinetd[2578]: Starting hard reconfiguration
Jan  8 02:15:56 e-smith xinetd[2578]: readjusting service auth
Jan  8 02:15:56 e-smith xinetd[2578]: readjusting service auth
Jan  8 02:15:56 e-smith xinetd[2578]: readjusting service ftp
Jan  8 02:15:56 e-smith xinetd[2578]: readjusting service ftp
Jan  8 02:15:56 e-smith xinetd[2578]: readjusting service telnet
Jan  8 02:15:56 e-smith xinetd[2578]: readjusting service telnet
Jan  8 02:15:56 e-smith xinetd[2578]: warning: can't get client address:
Bad file descriptor
Jan  8 02:15:56 e-smith xinetd[2578]: warning: can't get client address:
Bad file descriptor
Jan  8 02:15:56 e-smith xinetd[2578]: refused connect from 192.168.16.90
Jan  8 02:15:56 e-smith xinetd[2578]: refused connect from 192.168.16.90
Jan  8 02:15:56 e-smith xinetd[2578]: telnet server 2582 failed libwrap
check
Jan  8 02:15:56 e-smith xinetd[2578]: telnet server 2582 failed libwrap
check
Jan  8 02:15:56 e-smith xinetd[2578]: Sending signal 9 to telnet server
2582
Jan  8 02:15:56 e-smith xinetd[2578]: Sending signal 9 to telnet server
2582
Jan  8 02:15:56 e-smith xinetd[2578]: warning: can't get client address:
Bad file descriptor
Jan  8 02:15:56 e-smith xinetd[2578]: warning: can't get client address:
Bad file descriptor
Jan  8 02:15:56 e-smith xinetd[2578]: refused connect from 192.168.16.90
Jan  8 02:15:56 e-smith xinetd[2578]: refused connect from 192.168.16.90
Jan  8 02:15:56 e-smith xinetd[2578]: telnet server 2582 failed libwrap
check
Jan  8 02:15:56 e-smith xinetd[2578]: telnet server 2582 failed libwrap
check
Jan  8 02:15:56 e-smith xinetd[2578]: Sending signal 9 to telnet server
2582
Jan  8 02:15:56 e-smith xinetd[2578]: Sending signal 9 to telnet server
2582
Jan  8 02:15:56 e-smith xinetd[2578]: readjusting service imap
Jan  8 02:15:56 e-smith xinetd[2578]: readjusting service imap
Jan  8 02:15:56 e-smith xinetd[2578]: readjusting service pop-3
Jan  8 02:15:56 e-smith xinetd[2578]: readjusting service pop-3
Jan  8 02:15:56 e-smith xinetd[2578]: readjusting service smtp
Jan  8 02:15:56 e-smith xinetd[2578]: readjusting service smtp
Jan  8 02:15:56 e-smith xinetd[2578]: Reconfigured: new=0 old=6 dropped=0
(services)
Jan  8 02:15:56 e-smith xinetd[2578]: Reconfigured: new=0 old=6 dropped=0
(services)

I don't touch /etc/hosts.allow, /etc/hosts.deny contains ALL:ALL, and I'm
able to connect to the telnet server from the same IP before and after the
USR2 with the exact same access rules.

Does this seem strange?
Comment 1 Trond Eivind Glomsrxd 2001-01-09 14:55:03 EST
Reproduced... something seems to be not quite right in xinetd when changing the
file.
Comment 2 Trond Eivind Glomsrxd 2001-01-20 18:27:48 EST
Fixed in xinetd-2.1.8.9pre14-1

Note You need to log in before you can comment on or make changes to this bug.