Bug 23651 - "rpm -e" removes package from database even on errors
Summary: "rpm -e" removes package from database even on errors
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-09 14:20 UTC by jlehrke
Modified: 2007-04-24 18:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-09 14:20:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jlehrke 2001-01-09 14:20:06 UTC
"rpm -e" removes the package from the database even if the package files
can not be removed due to e.g. read-only file systems. Without enforcement
(--force) it should print out the error messages and not touch the
database. To ensure a consistent system rpm must prove (e.g. by touching
the package files), that all files are removable before it removes a
package.

Comment 1 Jeff Johnson 2001-01-09 14:49:34 UTC
You need to add you RO files systems to rpm configuration, something like
	mkdir -p /etc/rpm
	echp "%_netsharedpath /path/to/fs/1:/path/to/fs/2" >> /etc/rpm/macros


Note You need to log in before you can comment on or make changes to this bug.