Bug 236520 - install hangs computing dependencies (FC7 t3)
install hangs computing dependencies (FC7 t3)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-15 20:29 EDT by Tom Horsley
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-18 11:13:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2007-04-15 20:29:04 EDT
Description of problem:

I get to the point where the installer says it is computing dependences for
the selected packages and it never comes back, and no progress is ever
reported in the progress bar for the dialog that pops up.

Version-Release number of selected component (if applicable):

f7-test3-prime-x86_64/F-6.92-x86_64-DVD.iso

How reproducible:

Happened both times I tried with different sets of packages.

Steps to Reproduce:
1. get to the initial package selection screen and click on software
development, clearing the originally selected office & productivity
choice.
2. click on next
3. wait
  
Actual results:

In the above case I waited about 15 minutes and nothing on the screen
ever changed except the animated cursor going in circles. No progress
in progress bar.

Expected results:

Som progress would be nice, making through the check would be even better.

Additional info:

The first time I tried it, I did custom packages and selected all optional
for everything except languages, virtualization, and unclassified. I gave
that one about 45 minutes with the same result - never got anywhere.
Comment 1 Jeremy Katz 2007-04-16 10:04:26 EDT
Can you switch ttys when it's still sitting there?  If so, switch to tty2 and
try to look at what's being done.  Note that since you're doing a net install,
if you're going from a mirror that's slower, then it can take a while.

And the progress bar should be fixed post test3
Comment 2 Tom Horsley 2007-04-16 10:18:19 EDT
I'll give it a try when I get home, but I'm not doing a network install,
I'm telling it to install from the DVD iso image file on a local disk
(if that matters).
Comment 3 Riku Seppala 2007-04-16 11:35:08 EDT
I'm having this same problem, waited for about 20 minutes. Installing from
local-cdrom. I don't know about tty numbers, ctrl+alt+f1 is that tty1? f2 tty2
and so on? anyway:

1 last line: No handlers could be found for logger "yum.YumBase"

2 only line: sh-3.2#

3 ... selected kernel package for kernel

on the upper lines there's few warnings:
step installtype does not exist
step complete does not exist
and one error:
error scanning mpaths, disabling: (2, 'No such file or directory')


********** just when got those typed the installer went forward. Also just on
the mailing-list
https://www.redhat.com/archives/fedora-test-list/2007-April/msg00288.html

Comment 4 Tom Horsley 2007-04-16 18:02:13 EDT
OK, I tried the install again, and looked at various Ctrl-Alt-F* ttys
and I see the same No handlers could be found for logger "yum.YumBase"
that was reported above in tty1. In tty2 I was able to run top and
it said anaconda was using 50% of the cpu pretty continuously. There
were two anaconda processes, one parent, and one child, and it seemed
to be the parent that was getting all the cpu time. The only other
interesting processes running were Xorg and mini-wm. There were a lot
of interesting things in the other ttys, but nothing understandable
by me :-).

While doing all this poking around, the dependency resolution apparently
finished, because when I finally got back to Ctrl-Atl-F6, it was prompting
me to hit Next.

I did that and was able to complete the install, but physically installing
all the packages took about the same time as the dependency computation, so
something is just horribly slow in there. Once again this was with my initial
example of just having "Software Development" selected. God knows how long
it might take to actually finish with all optional packages selected in
every package group.

Don't know if the power management software is setting the clock speed to
60 HZ or what, but something has made the dependency checking massively
slower than it was on FC6.
Comment 5 Will Woods 2007-04-16 18:11:44 EDT
It was known to be very slow in Test3, and should be faster in Test4. Also the
progress bar should update properly.
Comment 6 Jeremy Katz 2007-04-18 11:13:37 EDT
Yeah, this sounds like it should be a lot better for test4.  Please try again
and if you have problems there, file another bug with specific details.
Comment 7 Tom Horsley 2007-04-18 16:36:17 EDT
Just as a matter of idle curiosity: Does the installation media contain
a pre-computed dependency graph for all the included rpms? Or is it computing
the dependencis by reading the headers from the rpms at install time?
In my state of complete ignorance, I imagine that a pre-computed graph
could save a lot of time at installation :-).

Note You need to log in before you can comment on or make changes to this bug.