Bug 236751 - oowriter has no implemenation of the /s flag for the SEQ field in .doc import
oowriter has no implemenation of the /s flag for the SEQ field in .doc import
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-17 11:06 EDT by Thomas J. Baker
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 08:32:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
doc file that oowriter incorrectly parses (1.24 MB, application/octet-stream)
2007-04-17 11:06 EDT, Thomas J. Baker
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 19981 None None None Never
OpenOffice.org 76689 None None None Never

  None (edit)
Description Thomas J. Baker 2007-04-17 11:06:23 EDT
From one of my users:

Attached is the file whose pages change depending upon the software
that opens the file.  KDE's kwrite shows the correct information
(no Table 3-6).  OpenOffice shows the wrong information (includes
a Table 3-6, which the document had in early revisions).
Comment 1 Thomas J. Baker 2007-04-17 11:06:25 EDT
Created attachment 152815 [details]
doc file that oowriter incorrectly parses
Comment 2 Caolan McNamara 2007-04-17 12:18:09 EDT
i.e. we have the table numbers wrong we say...

Table 1‑1.  Referenced Documents	10
Table 3‑2.  CSCI Descriptions & Criticality	15
Table 3‑3.  NASA Criticality Classifications	17
Table 3‑4.  Language Summary	18
Table 3‑5.  Language Justification	18
Table 3‑6.  DPU Flight Software Development Environment	20
Table 4‑7.  NPR 7150.2 Chapter 2 Requirements Mapping	21
Table 4‑8.  NPR 7150.2 Chapter 3 Requirements Mapping	22
Table 4‑9.  NPR 7150.2 Chapter 4 Requirements Mapping	23
Table 4‑10.  NPR 7150.2 Chapter 5 Requirements Mapping	24
Table 7‑11.  Artifact To CSCI Cross Reference	36
Table 7‑12.  Artifact Description Table	37
Table 8‑13.  Failure Severity Categories For The SEISS-To-Spacecraft Interface
And Redundancy Implementation FMECA’s Per The IMAR	57
Table 8‑14.  Failure Severity Categories For The Test Equipment-To-SEISS
Interface	57
when we should say...

Table 1‑1.  Referenced Documents	10
Table 3‑1.  CSCI Descriptions & Criticality	15
Table 3‑2.  NASA Criticality Classifications	17
Table 3‑3.  Language Summary	18
Table 3‑4.  Language Justification	18
Table 3‑5.  DPU Flight Software Development Environment	20
Table 4‑1.  NPR 7150.2 Chapter 2 Requirements Mapping	21
Table 4‑2.  NPR 7150.2 Chapter 3 Requirements Mapping	22
Table 4‑3.  NPR 7150.2 Chapter 4 Requirements Mapping	23
Table 4‑4.  NPR 7150.2 Chapter 5 Requirements Mapping	24
Table 7‑1.  Artifact To CSCI Cross Reference	36
Table 7‑2.  Artifact Description Table	37
Table 8‑1.  Failure Severity Categories For The SEISS-To-Spacecraft Interface
And Redundancy Implementation FMECA’s Per The IMAR	57
Table 8‑2.  Failure Severity Categories For The Test Equipment-To-SEISS Interface	57
Comment 3 Caolan McNamara 2007-04-17 12:35:02 EDT
The problem is that we have no equivalent in OOo for the "\s" option for the
msword SEQ field, which means something like "push the current value onto a
stack, and then reset the sequence to 1 when entering into a part of the
document which begins with a style which has a higher position in the outline
table and pop the previous value when moving to a lower position"
Comment 4 Caolan McNamara 2007-04-25 08:32:17 EDT
oky doky, so I'm implemented a handler for this /s flag and submitted it as
http://www.openoffice.org/issues/show_bug.cgi?id=76689 you can track progress of
this feature at that location.

Note You need to log in before you can comment on or make changes to this bug.