Bug 236875 - autofs problem with symbolic links
autofs problem with symbolic links
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Martin Jenner
: Regression
Depends On:
Blocks: 253231
  Show dependency treegraph
 
Reported: 2007-04-18 03:24 EDT by Ian Kent
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 14:47:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to resolve race between mount and expire (9.25 KB, patch)
2007-04-18 03:24 EDT, Ian Kent
no flags Details | Diff
Patch to fix wakeup order of processes when rehashing dentry (833 bytes, patch)
2007-08-20 01:40 EDT, Ian Kent
no flags Details | Diff
Patch to sync autofs4 with upstream (1.27 KB, patch)
2007-08-27 07:43 EDT, Ian Kent
no flags Details | Diff
Patch to fix issue reported during QA (563 bytes, patch)
2007-08-27 07:47 EDT, Ian Kent
no flags Details | Diff

  None (edit)
Comment 1 Ian Kent 2007-04-18 03:24:52 EDT
Created attachment 152877 [details]
Patch to resolve race between mount and expire
Comment 2 RHEL Product and Program Management 2007-04-18 03:45:46 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 RHEL Product and Program Management 2007-04-18 05:21:59 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 4 Don Zickus 2007-05-09 14:14:58 EDT
in 2.6.18-18.el5
Comment 7 Ian Kent 2007-08-20 01:40:24 EDT
Created attachment 161844 [details]
Patch to fix wakeup order of processes when rehashing dentry

I've discovered a problem with the patch for this issue.
It is related to the wakeup order of waiting processes.

Ian
Comment 8 Ian Kent 2007-08-27 07:43:00 EDT
Created attachment 173481 [details]
Patch to sync autofs4 with upstream

Due to a problem uncovered during QA of this patch
for a RHEL-4 Z-Stream update I've had to revisit this
issue.

There are a couple of patches now that depend on this
patch and there is a risk of some confusion regarding
the various patches. To try and avoid this we should
be able to use the same patches everywhere so we need
to sync the source of the various kernels with upstream.

This patch wasn't needed for this originally but is now
needed by the fix for the problem identified above during
QA and for other bugs that depend on these patches (for
example see bug #253231).
Comment 9 Ian Kent 2007-08-27 07:47:14 EDT
Created attachment 173501 [details]
Patch to fix issue reported during QA

This patch fixes a fail reported during QA testing for
a Z-Stream release for RHEL 4.

It is in fact a hunk from another autofs4 patch that
resolves a deadlock during directory creation under load
(see bug #253231 for info). The deadlock patch delays hashing
of dentrys at directory creation until the actual create
operation and so dentrys remain unhashed for a relatively
long time so the code in this patch was needed their. With
the expire/mount race fix here, dentrys are unhashed for a
relatively brief time so the code in this patch was not
identified as needed during development. However, if there
are many process concurrently accessing directories it's
possible there will be two or more waiters in the queue.
Only one of the waiter will have the dentry required to
complete the lookup and the others need to perform a
d_lookup to get the correct dentry.

This patch allows these processes to perform the needed
d_lookup.
Comment 10 Martin Jenner 2007-08-27 15:39:37 EDT
a little late but placing in state for fails qa.
Comment 15 Don Zickus 2007-08-28 18:33:32 EDT
in 2.6.18-44.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 18 errata-xmlrpc 2007-11-07 14:47:01 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html

Note You need to log in before you can comment on or make changes to this bug.