Bug 236916 - Remove alsactl from the halt script
Remove alsactl from the halt script
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: 236285
  Show dependency treegraph
 
Reported: 2007-04-18 09:09 EDT by Martin Stransky
Modified: 2014-03-16 23:06 EDT (History)
2 users (show)

See Also:
Fixed In Version: 8.53-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 15:57:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (474 bytes, patch)
2007-04-18 09:09 EDT, Martin Stransky
no flags Details | Diff

  None (edit)
Description Martin Stransky 2007-04-18 09:09:02 EDT
Description of problem:

Because of Bug 236285, we need to move ALSA volume settins from /etc to
/etc/alsa/. There's updated salsa utlity which can handle it, so we don't have
to care about alsactl any more. Proposed patch is attached.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Martin Stransky 2007-04-18 09:09:02 EDT
Created attachment 152898 [details]
proposed patch
Comment 2 Bill Nottingham 2007-04-18 14:24:27 EDT
This makes the call from something generic supported by upstream ALSA to
something RH specific. Why not just configure alsactl with a different default?
Comment 3 Martin Stransky 2007-04-19 05:53:11 EDT
I don't think so. Upstream doesn't care about our distro specific issues, like
how we handle the module loading, where we save the configuration and so on.

But you're right. We can use "alsactl -f /etc/alsa/asound.state store". But I
prefer to have one, unified and simple command for loading/storing the volume
settings.  And "salsa -l" is only a wrapper and it calls "alsactl -f
/etc/alsa/asound.state store" anyway.

There're two more benefits - if we decide to change the default we will change
only one small utility (instead of new kudzu/initscripts/udev rules changes).

And if there isn't any stored configuration (/etc/alsa/asound.state) we can
andjust the mixer with the default values (via. alsaunmute).
Comment 4 Bill Nottingham 2007-04-19 13:40:30 EDT
What version of alsa-utils does initscripts need to require/conflict with?
Comment 5 Martin Stransky 2007-04-19 15:37:28 EDT
The updated salsa is in alsa-utils-1.0.14-0.5.rc2.fc7 so the new initscripts should:

require >= alsa-utils-1.0.14-0.5.rc2.fc7 
conflict with < alsa-utils-1.0.14-0.5.rc2.fc7
Comment 6 Bill Nottingham 2007-04-19 15:57:08 EDT
Added in CVS, will be in 8.53-1.
Comment 7 Robert Scheck 2007-04-28 04:00:06 EDT
Nope, don't add any require to alsa-utils. Initscripts does NOT depend on alsa-
utils, it only has problems with older versions, so ONLY add conflict!
Comment 8 Martin Stransky 2007-04-30 05:08:08 EDT
alsa-utils doesn't have any requires/conflicts for initscripts because it works
fine with all versions of them.

Note You need to log in before you can comment on or make changes to this bug.