Bug 236917 - nmap can't be rebuilded
Summary: nmap can't be rebuilded
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nmap   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Michal Hlavinka
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-18 13:24 UTC by Mykola Ulianytskyi
Modified: 2008-09-18 13:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-18 13:51:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fix build issue (275 bytes, text/x-patch)
2007-04-18 13:25 UTC, Mykola Ulianytskyi
no flags Details

Description Mykola Ulianytskyi 2007-04-18 13:24:19 UTC
Description of problem:
   nmap can't be rebuilded

Version-Release number of selected component (if applicable):
   glibc-headers-2.5-12
   kernel-headers-2.6.18-8.el5
   nmap-4.11-1.1
 
Steps to Reproduce:
rpmbuild -ba nmap.spec

...  
gcc -g -O2 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic
-fasynchronous-unwind-tables -fno-strict-aliasing -I.  -DHAVE_CONFIG_H 
-D_U_="__attribute__((unused))" -c ./fad-getad.c
In file included from ./fad-getad.c:64:
/usr/include/linux/if_packet.h:52: error: expected specifier-qualifier-list
before '__u32'
make[1]: *** [fad-getad.o] Error 1
...

Comment 1 Mykola Ulianytskyi 2007-04-18 13:25:18 UTC
Created attachment 152903 [details]
Patch fix build issue

Patch fix build issue

Comment 2 RHEL Product and Program Management 2007-12-03 20:42:04 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.

Comment 3 Tomas Smetana 2008-04-01 13:24:26 UTC
Setting flags for 5.3.

Comment 4 RHEL Product and Program Management 2008-07-21 23:11:20 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 5 Michal Hlavinka 2008-09-18 13:51:21 UTC
Bug was reported for RHEL 5.0.
Tested in RHEL 5.2 with packages:
nmap-4.11-1.1
glibc-headers-2.5-24
kernel-headers-2.6.18-92.1.6.el5

and working.


Note You need to log in before you can comment on or make changes to this bug.