Bug 236919 - RFE - Update jpilot to include keyring support
RFE - Update jpilot to include keyring support
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: jpilot (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-18 09:45 EDT by Phil Schaffner
Modified: 2010-04-13 10:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 10:02:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 1936 None None None Never

  None (edit)
Description Phil Schaffner 2007-04-18 09:45:01 EDT
Description of problem:
jpilot is currently compiled without a build dependency on openssl-devel
resulting in the keyring plugin not being build.  FC6 version jpilot-0.99.8-8
corrects this problem.

Version-Release number of selected component (if applicable):
jpilot-0.99.8-7.1

How reproducible:
always

Steps to Reproduce:
1. Run jpilot
2. Select "Plugins" from menu
3. 
  
Actual results:
"Keyring" plugin is missing.

Expected results:
"Keyring" plugin should be present.

Additional info:
Fixed in FC6 - BZ# 214042
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=214042
Comment 1 RHEL Product and Program Management 2007-06-05 16:31:26 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 2 David Ash 2007-07-16 00:44:07 EDT
Would be good to get this reconsidered for rhel5.  Otherwise I have to use
unsupported rpms.
Comment 3 Phil Schaffner 2007-07-16 10:45:32 EDT
Ditto.

Also, not sure what was meant in the closure comment by "this bugzilla is in a
component that is not approved for the current release" as both jpilot and
openssl are part of the current release.  The only change required is to have a
jpilot build dependency on openssl-devel, a seemingly trivial change to add the
missing functionality.
Comment 4 David Ash 2007-07-18 03:19:54 EDT
Yes so either this is a bug and should be fixed, or this upstream feature (which
is fixed in fedora) was accidently included into our RHEL release though was not
approved.

Is there good reason to not fix this bug Ivana?
Comment 5 Phil Schaffner 2008-12-12 08:24:27 EST
Long time with no action here.  I have been using a locally-built package with this minor fix for some time.  "Is there good reason to not fix this bug Ivana?"
Comment 6 Ivana Varekova 2008-12-15 08:14:49 EST
The decision is up to the product management - I will ask them, but please use the proper support channel to increase the importance of this issue.
Comment 7 David Ash 2009-01-21 02:05:42 EST
Hi Philip.  I should have said this ages ago.  But just wondering if your still requiring this fix if you could please open a support case with Red Hat Global Support Services so we can escalate this appropriately.
Comment 8 Phil Schaffner 2009-01-21 13:15:52 EST
David,

My support has lapsed since this has been open.  Currently using my rebuilt RPM on CentOS so opening a support case is not currently an option.  Still seems like an easy/obvious fix, given that the FC6 version was OK, as is F10.
Comment 9 Ivana Varekova 2010-04-13 10:02:18 EDT
This problem is resolved in the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.