Bug 236920 - policycoreutils missing sed requirement
policycoreutils missing sed requirement
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: policycoreutils (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-18 09:49 EDT by Martin Poole
Modified: 2010-10-22 10:25 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0543
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 13:04:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Poole 2007-04-18 09:49:35 EDT
Description of problem:

Appears to be missing a dependency on sed

Version-Release number of selected component (if applicable):

policycoreutils-1.33.12-3.el5

How reproducible:

Always

Steps to Reproduce:

/sbin/fixfiles calls sed, while policycoreutils which provides fixfiles, does
not require it. This causes errors during system installation in the
install.log, causing post-install scripts to fail.

Since fixfiles calls sed directly, it really should reflect this requirement in
the policycoreutils rpm.

  
Actual results:


Expected results:


Additional info:


/sbin/fixfiles is a script .. it calls sed ...


diff_filecontext() {
if [ -f ${PREFC} -a -x /usr/bin/diff ]; then
       TEMPFILE=`mktemp ${FC}.XXXXXXXXXX`
       test -z "$TEMPFILE" && exit
       PREFCTEMPFILE=`mktemp ${PREFC}.XXXXXXXXXX`
       sed -r -e 's,:s0, ,g' $PREFC | sort -u > ${PREFCTEMPFILE}
Comment 2 RHEL Product and Program Management 2007-06-04 16:24:20 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Daniel Walsh 2007-06-21 15:57:00 EDT
Fixed in policycoreutils-1.33.12-10.el5
Comment 5 Issue Tracker 2007-06-22 14:52:14 EDT
----- Additional Comments From gcwilson@us.ibm.com  2007-06-22 14:16 EDT
-------
Hi Dan,

Can you make policycoreutils-1.33.12-10.el5 rpms available on your people
page? 


This event sent from IssueTracker by jkachuck 
 issue 118970
Comment 6 Daniel Walsh 2007-06-22 15:52:53 EDT
Yes just as soon as it passes the test procedures.  IE Expect 11 soon.  :^)
Comment 10 errata-xmlrpc 2007-11-07 13:04:06 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0543.html

Note You need to log in before you can comment on or make changes to this bug.