Bug 237075 - qtparted fails to load
Summary: qtparted fails to load
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qtparted (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Steven Pritchard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 241053 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-04-19 10:56 UTC by Stephanos Manos
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version: 0.4.5-15.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 16:44:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephanos Manos 2007-04-19 10:56:12 UTC
Description of problem:
when starting qtparted a popup window appears with "unknown error" 

Version-Release number of selected component (if applicable):
qtparted-0.4.5-14.fc7

How reproducible:
always 

Steps to Reproduce:
1. Install the app
2. run the app from the menu (Applications -> System Tools -> QTParted)
  
Actual results:
The above mentioned popup window

Expected results:
The app to launch

Additional info:
The problem is with the pam file (/etc/pam.d/qtparted)
changing it to match another (i.e. qparted) then the app starts

Comment 1 Bill Nottingham 2007-05-25 21:35:16 UTC
*** Bug 241053 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 2007-05-25 21:35:52 UTC
See: http://docs.fedoraproject.org/release-notes/fc5/#id3004442

Comment 3 Steven Pritchard 2007-05-25 21:46:59 UTC
(In reply to comment #2)
> See: http://docs.fedoraproject.org/release-notes/fc5/#id3004442

Fun.  I'll try to get this fixed ASAP.  Thanks for pointing me in the right 
direction.

Comment 4 Stephanos Manos 2007-08-27 14:14:27 UTC
Any news as to when this will be fixed?

Comment 5 Doncho Gunchev 2007-09-03 10:24:45 UTC
The fix is simple - copy /etc/pam.d/gparted to /etc/pam.d/qtparted and it 
works. Here's a diff:

$ diff -bu qtparted.bad qtparted
--- qtparted.bad       2004-11-08 07:17:31.000000000 +0200
+++ qtparted    2007-09-03 13:16:48.000000000 +0300
@@ -1,6 +1,8 @@
 #%PAM-1.0
 auth       sufficient   pam_rootok.so
-auth       required     pam_stack.so service=system-auth
-account    required     pam_permit.so
+auth   sufficient      pam_timestamp.so
+auth   include         system-auth
 session    required     pam_permit.so
 session    optional     pam_xauth.so
+session        optional        pam_timestamp.so
+account        required        pam_permit.so


Comment 6 Fedora Update System 2007-09-10 16:51:09 UTC
qtparted-0.4.5-15.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Stephanos Manos 2007-09-10 23:06:28 UTC
Fixed.
Thanks

Comment 8 Fedora Update System 2007-09-12 16:44:47 UTC
qtparted-0.4.5-15.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.