Bug 237105 - Emacs always opens with the same screen
Emacs always opens with the same screen
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Coldwell
:
: 238618 261561 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-19 09:33 EDT by Paul Black
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 10:24:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Black 2007-04-19 09:33:13 EDT
Description of problem:
When runing emacs with a file argument, 

Version-Release number of selected component (if applicable):
emacs-22.0.95-1.fc7

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Paul Black 2007-04-19 09:35:47 EDT
Didn't let me finish!

Description of problem:
When runing emacs with a file argument, emacs always opens with the same info
screen and a "Type C-l to start editing"

Version-Release number of selected component (if applicable):
emacs-22.0.95-1.fc7

How reproducible:
Every time

Steps to Reproduce:
1. Run emacs with a file as an argument, e.g. "emacs .cshrc"
  
Actual results:
Emacs has an initial screen before showing the file to be edited

Expected results:
Show the file to be edited immediately.
Comment 2 Chip Coldwell 2007-04-19 10:24:20 EDT
(setq inhibit-splash-screen t)
Comment 3 Chip Coldwell 2007-05-10 09:39:23 EDT
*** Bug 238618 has been marked as a duplicate of this bug. ***
Comment 4 Daryll 2007-05-10 09:56:24 EDT
This is a change from the previous behavior.

Making the user look at the splash screen every time, even when they've
explicitly asked to edit a file, is really annoying. It amounts to an
advertisement before every I edit every file.

Yes, one could put that line in their .emacs file, but they've got to do that on
every system and on every account they use. In my case, there are a lot of
systems where I might want to quickly edit a file.

Isn't there some way to revert to previous behavior as the default? I think
you'll get a lot of complaints about this.

Comment 5 Chip Coldwell 2007-05-10 10:20:13 EDT
(In reply to comment #4)
> This is a change from the previous behavior.

Yes.

http://lists.gnu.org/archive/html/emacs-devel/2002-05/msg00863.html

I'm afraid you'll have to take that up with RMS.

> Isn't there some way to revert to previous behavior as the default?

Yes, put the following in your .emacs file:

(if (cadr command-line-args)
   (setq inhibit-splash-screen t))

Chip
Comment 6 Chip Coldwell 2007-08-29 13:45:11 EDT
*** Bug 261561 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.