This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 23713 - Anaconda uses wrong russian locale in instimage. See bug #16892 for details - it still exist
Anaconda uses wrong russian locale in instimage. See bug #16892 for details -...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-10 11:50 EST by Leonid Kanter
Modified: 2007-03-26 23:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-10 17:06:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
complete solution to fix this bug (418 bytes, patch)
2001-01-10 11:54 EST, Leonid Kanter
no flags Details | Diff

  None (edit)
Description Leonid Kanter 2001-01-10 11:50:04 EST
Basic character map for language "Russian" in Red Hat Linux is KOI8-R.
Locale directory for this charmap is currently
/usr/lib/locale/ru_RU.koi8r. Since LANG name for Russian is ru_RU.KOI8-R
(it's correct), script upd-instroot removes 
/usr/lib/locale/ru_RU.koi8r as unused. Please use my patch or find other
way to preserve ru_RU.koi8r for installation. 
As for /usr/lib/locale/ru_RU, it is for iso8859-5 charmap and it may be
removed without pain. My patch is tested.
Comment 1 Leonid Kanter 2001-01-10 11:54:27 EST
Created attachment 7365 [details]
complete solution to fix this bug
Comment 2 Matt Wilson 2001-01-10 17:06:49 EST
I've changed lang-table to refer to ru_RU.koi8r, which will properly preserve
the locale files for the install image.

You'll see this change in beta3
Comment 3 Brock Organ 2001-01-16 16:04:03 EST
verified fix in qa0116.3 ... thanks for your report!

Note You need to log in before you can comment on or make changes to this bug.