Bug 23716 - Internal compiler error in emit_swap_insn. gcc-2.96-69
Summary: Internal compiler error in emit_swap_insn. gcc-2.96-69
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 25162 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-10 18:40 UTC by Michel Selten
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-11 21:28:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the output gcc generates with the additional -save-temps -v flags (251.00 KB, text/plain)
2001-01-11 21:28 UTC, Michel Selten
no flags Details

Description Michel Selten 2001-01-10 18:40:57 UTC
This error occurred when building the Crystal Space package from CVS
(Januari 8th).

make all
*-------------------------------------------------------------------------*
  Building CrystalClear entity library
  Building for LINUX/GCC/INTEL in optimize mode
*-------------------------------------------------------------------------*
make[1]: Nothing to be done for `csclearlib'.
*-------------------------------------------------------------------------*
  Building Crystal Space 3D engine
  Building for LINUX/GCC/INTEL in optimize mode
*-------------------------------------------------------------------------*
gcc -c -o out/LINUX/INTEL/optimize/camera.o libs/csengine/camera.cpp -Wall
-Wunused -W -mpentiumpro -march=i686 -fno-exceptions -fno-rtti -O6
-fomit-frame-pointer -ffast-math -I. -I./apps -I./include -I./libs
-I./plugins -I./support
libs/csengine/camera.cpp: In method `void csCamera::LookAt (const 
csVector3 &, const csVector3 &)':
libs/csengine/camera.cpp:163: Internal compiler error in emit_swap_insn
, at reg-stack.c:965
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [out/LINUX/INTEL/optimize/camera.o] Error 1
make: *** [csengine] Error 2

Comment 1 Michel Selten 2001-01-10 20:07:49 UTC
I forgot some (maybe important) information:
processor: AMD-Athlon 750Mhz
mem: 128M
Linux Kernel: 2.4.0-test8


Comment 2 Jakub Jelinek 2001-01-11 14:52:28 UTC
Please rerun
gcc -c -o out/LINUX/INTEL/optimize/camera.o libs/csengine/camera.cpp -Wall
-Wunused -W -mpentiumpro -march=i686 -fno-exceptions -fno-rtti -O6
-fomit-frame-pointer -ffast-math -I. -I./apps -I./include -I./libs
-I./plugins -I./support -save-temps -v
and attach here camera.ii it creates.

Comment 3 Michel Selten 2001-01-11 21:28:38 UTC
Created attachment 7464 [details]
This is the output gcc generates with the additional -save-temps -v flags

Comment 4 Jakub Jelinek 2001-01-12 12:22:34 UTC
The constraints in include/qsqrt.h are bogus, you cannot request
ret be returned in st while at the same time requesting it not to be returned
in st. Removing "st" from the list of clobbers should fix this.
As for why gcc segfaults on this, it should not but gcc previously did even
less checking of the correctness of asm constraints, so I definitely don't
consider it high priority for fixing.

Comment 5 Jakub Jelinek 2001-01-31 10:28:39 UTC
*** Bug 25162 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.