Bug 237238 - The API documentation is missing
The API documentation is missing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-20 05:53 EDT by Frank Büttner
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-04 09:17:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Büttner 2007-04-20 05:53:00 EDT
Description of problem:
In the subpackge rpm-devel the api doc is complete missing.
The directory /usr/share/doc/rpm-devel-4.4.2/apidocs don't contains any files.

Version-Release number of selected component (if applicable):
rpm-devel-4.4.2-32
Comment 1 Jeff Johnson 2007-04-20 07:56:32 EDT
The API doco goes missing every time rpm is built on a system without doxygen installed.

The API doco is not tracked with a dependency and is handled optionally for RHL 7x
hysterical reasons (doxygen was not present everywhere) and because doxygen includes
a subpkg that depends on Qt (the licensing at one point in time was wrong) and because
KDE is a huge build dependency for a build tool like rpm to carry.
Comment 2 Frank Büttner 2007-04-20 08:39:43 EDT
You can simple add the doxygen dependency at the build require part of the spec
file. And for Qt you don't need KDE. It is an stand alone package. 
Comment 3 Jeff Johnson 2007-04-20 08:54:15 EDT
Yep.
Comment 4 Michael Jennings (KainX) 2007-04-20 11:53:56 EDT
(In reply to comment #2)
> You can simple add the doxygen dependency at the build require part of the spec
> file. And for Qt you don't need KDE. It is an stand alone package. 

No, you missed the point.  The doxygen dependency was explicitly, intentionally
NOT listed because rpm is a core OS package.  Qt is not, and is in fact quite
heavy with dependencies of its own.  It would be far too costly in terms of
dependency overhead to *require* doxygen (and thus Qt, X libs, libjpeg, libpng,
libtiff, libmng, fontconfig, ...ad nauseum) for something as low-level as RPM. 
Thus, API docs are built if doxygen is there and not if it isn't.  Perfectly
sane and reasonable since they are not required for proper RPM functionality.

NOTABUG
Comment 5 Panu Matilainen 2007-07-04 09:17:39 EDT
Rawhide rpm has the api generation re-enabled (again)

Note You need to log in before you can comment on or make changes to this bug.