Bug 23729 - OSError
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-01-10 15:29 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-01 13:34:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-01-10 15:29:57 EST
ne 20, in run
file"/var/tmp/anaconda-7.0.1/usr/lib/anaconda/todo.py",line 1470, in 
iutil.mkdir Chain(kmp/swap)
file"/var/tmp/anaconda-7.0.1/usr/lib/anaconda/iutil.py",line 193, in 
os.mkdir(path 0755)
OSError:[Errno28] no space left on device: /tmp/swap
Comment 1 Need Real Name 2001-01-10 16:06:13 EST
I was trying to load redhat 7 and in the setting up of the hard drive or 
formating I received this error.  I tried to do a fdisk but the system will not 
open the device.  It is like there is no hard drive.  I have gone to windows 
and tried to access the drive and there is nothing.  Fdisk in DOS shows no 
drive.  How do I get my hard drive back?  The drive is a 4.3 Gb and the chip is 
a 333 Intel.
Comment 2 Michael Fulbright 2001-01-10 16:25:48 EST
What type of drive is this? What kind of interface is it connected to?
Comment 3 Need Real Name 2001-01-11 12:18:24 EST
The hard drive is a Fujitsu  model MPC3043AT, 4.3GB, ISA.  The BIOS shows no 
drive and I can not define it in the BIOS.  I have removeable hard drives so I 
can snap in the drivve for Windows or remove it and snap in the drive for Linux.
When the Linux software was formating the drive I received the error. HELP.
Comment 4 Michael Fulbright 2001-01-26 18:31:29 EST
I am not sure how I can help - if the drive does not get detected by BIOS I do
not think the Linux kernel is going to see it.
Comment 5 Need Real Name 2001-01-27 12:51:42 EST
I recovered my hard drive.  I had to manually define the hard drive to the 
BIOS.  Then I used debug to low level format the drive.  Then I used Microsoft 
fdisk to portion the drive and then formated for FAT 32.  I now have my hard 
drive working.  I don't know what Linux is doing but it sure destored the 
drive.  If you know of some other way of correcting the problem, let me know.
Comment 6 Michael Fulbright 2001-02-01 13:34:31 EST
If you used the fdisk /mbr command from a windows boot floppy, it should make
you able to boot windows again.
Comment 7 Michael Fulbright 2001-02-23 12:28:54 EST
Closing due to inactivity.

Note You need to log in before you can comment on or make changes to this bug.