Bug 237314 - system-config-network should obsolete 'netconfig'
system-config-network should obsolete 'netconfig'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: 222082 237268
  Show dependency treegraph
 
Reported: 2007-04-20 15:22 EDT by David Cantrell
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHEA-2007-0852
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:56:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Cantrell 2007-04-20 15:22:17 EDT
This is related to bug #237268.  pump is no longer part of RHEL-5. 
Unfortunately, the package 'netconfig' which was built from the pump source RPM
fell in to the RHEL-5 tree.  Users that fire up netconfig to configure their
network interface will end up with broken ifcfg scripts.  My desire is to have
this package removed for RHEL-5.1.

The system-config-network package should obsolete netconfig in this case.
Comment 1 David Cantrell 2007-07-24 14:32:17 EDT
The spec file for this package should be updated for 5.1 to complete the removal
of pump from the distribution.  I feel this is an exception for 5.1 and should
be allowed in since the pump removal required touching a number of packages.

All I want is an Obsoletes line added to the system-config-network spec file and
the package rebuilt.
Comment 4 Don Domingo 2007-08-14 00:38:58 EDT
will this work (for the release notes)?

<quote>
pump is deprecated in this update. As such, configuring your network interface
through netconfig may result in broken ifcfg scripts. 

To configure your network interface, use system-config-network instead.
</quote>

please advise if any revisions are necessary; i will add it to the release notes
upon approval. note that the deadline for the release notes is on 16 August 2007. 

thanks!
Comment 10 Don Domingo 2007-08-15 19:03:28 EDT
revising and adding release note as follows ("Other Updates"):

<quote>
pump is deprecated in this update. As such, configuring your network interface
through netconfig may result in broken ifcfg scripts.

To properly configure your network interface, use system-config-network instead.
Installing the updated system-config-network package removes netconfig.
</quote>

please advise within 24 hours if any revisions are necessary. the deadline for
the release notes is 16 August 2007 (Thursday), after which the releease notes
will be locked and pushed to L10n for translation. thanks!
Comment 11 errata-xmlrpc 2007-11-07 12:56:43 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0852.html

Note You need to log in before you can comment on or make changes to this bug.