Bug 237328 - Package search excludes x86_64 even when selected
Package search excludes x86_64 even when selected
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Devan Goodwin
wes hayutin
:
Depends On:
Blocks: 210537 248643
  Show dependency treegraph
 
Reported: 2007-04-20 16:22 EDT by Justin Sherrill
Modified: 2008-04-02 17:08 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 17:08:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2007-04-20 16:22:27 EDT
Description of problem:
When doing a package search on rhn.redhat.com with RHN 5.0, even if you select
to search with x86_64 it will omit any x86_64 packages. 

Looking at the URL that results (from a search with just x86_64 selected) I see
this:

https://rhn.redhat.com/network/software/packages/name_overview.pxt?package_name=sendmail&channel_arch_ia32=&channel_arch_ia64=&channel_arch_x86_64=&search_subscribed_channels=

Simply changing:

&channel_arch_x86_64=
to
&channel_arch_x86_64=channel-x86_64

fixes the issue for that search.  

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Search for a package selecting x86_64 in the search
2.
3.
  
Actual results:
Don't see any x86_64 packages


Expected results:
should see some x86_64 packages

Additional info:
Comment 2 Shannon Hughes 2007-04-25 06:16:30 EDT
dgoodwin, 

can you take a look at this and see if its similar to the other search bugs you
have looked at. 
Comment 3 Jan Pazdziora 2007-07-13 05:12:16 EDT
Setting the sat‑5.1.0 ? flag since the bug was under rhn500s-should.
Comment 5 Devan Goodwin 2007-10-29 09:30:15 EDT
This seems to be working now as a result of the search server work. Moving to ON_QA.
Comment 6 wes hayutin 2007-10-31 10:57:35 EDT
verified in build 23
Comment 7 Pradeep Kilambi 2008-03-18 12:30:53 EDT
yep shows x86_64 packages correctly in the search..release pending
Comment 8 Brandon Perkins 2008-04-02 17:08:48 EDT
UI Enhancements for 5.1 Sat GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.