Bug 237349 - mail-notification holding the processor at 100% randomly
mail-notification holding the processor at 100% randomly
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mail-notification (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-20 18:56 EDT by Russell Harrison
Modified: 2008-03-18 07:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 07:58:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Harrison 2007-04-20 18:56:52 EDT
Description of problem:
Occasionally mail-notification will get in a state where it takes as much of the
processor as it can get.  I think the conditions may be related to the fact the
laptop is on the wireless connection most of the time.  I'm not sure what the
case is where it will recover, but sometimes it does on its own and others I
need to kill it off.

Version-Release number of selected component (if applicable):
$ rpm -q mail-notification

mail-notification-4.0-1.fc6
Comment 1 Thorsten Leemhuis 2007-04-25 10:28:18 EDT
This problems seems to be tracked upstream; see
https://savannah.nongnu.org/bugs/?18367
Please participate there to get it fixed once and for all in all distributions;
there are no patches in fc6's mail-notification that should cause this, so
working directly upstream is the best here to get it fixed. I can act as a proxy
to upstream if you like, but a men in the middle in cases like this often makes
things worse.

Side note: I never hit such a problem with 4.0 (but I saw it with 3.0 in the past)
Comment 2 Russell Harrison 2007-04-27 12:20:14 EDT
Just because the fix needs to be made upstream first doesn't mean this bug
should be closed.  My understanding of "resolved upstream" is that there is an
upstream fix available, and the next version of the package should resolve the
issue.  Also by leaving this bug open people can subscribe to it rather than
opening duplicates.

I'm quite happy to work with upstream to resolve the bug, and will get them any
information they need.  I'm subscribing to the upstream bug (thanks for finding
it for me) and will post any updates here as well.
Comment 3 Thorsten Leemhuis 2007-04-27 13:15:27 EDT
(In reply to comment #2)
> Just because the fix needs to be made upstream first doesn't mean this bug
> should be closed.  My understanding of "resolved upstream" [...]

That was my understanding until not long ago, too, but then I read about it
again as one of my bugs got closed this way. See:

https://bugzilla.redhat.com/bugzilla/page.cgi?id=bug_status.html#resolution

"UPSTREAM [....] bugs closed with this resolution are filed in the upstream bug
tracker or reported to the upstream mailing list. This typically includes almost
all feature requests and enhancements, and most bugs that we don't consider
release showstoppers. [...]" There is more stuff there, but seems the way I've
done it valid.

> I'm quite happy to work with upstream to resolve the bug,

Many Thanks!

> will post any updates here as well.

thanks for that, too.

I don't care much if it's still open or closed so I'm leaving it open. But I'll
make it "needinfo" now, so it doesn't get into my way when listing other bugs.
That okay for you?
Comment 4 Russell Harrison 2007-04-28 12:44:08 EDT
(In reply to comment #3)
> "UPSTREAM [....] bugs closed with this resolution are filed in the upstream bug
> tracker or reported to the upstream mailing list. This typically includes almost
> all feature requests and enhancements, and most bugs that we don't consider
> release showstoppers. [...]" There is more stuff there, but seems the way I've
> done it valid.

Hmmm, it seems like there needs to be another category then.  If bugs are moved
to closed then they won't show up when new users discover the bug.  Then they'll
just open a new bug, eating up more cycles marking them as dupes.  UPSTREAM
makes more since as a major status similar to the POST status.  Anyway its an
academic point.

> I don't care much if it's still open or closed so I'm leaving it open. But I'll
> make it "needinfo" now, so it doesn't get into my way when listing other bugs.
> That okay for you?

That sounds like the proper status, it'll show up so people don't post dupes and
you do need more info before you could work on it anyway.  
Comment 5 Dmitry Butskoy 2008-03-18 07:58:41 EDT
Seems to already fixed, isn't it?

Note You need to log in before you can comment on or make changes to this bug.